Installed 1.0.2 and made Firefox default browser. Now cannot block and copy text. As soon as I release lh button, blocked text cancels.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: harrisgx, Assigned: bugzilla)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

I went back to IE and find that I can block, copy and paste text from there. 
Why won't it work with Firefox?

Reproducible: Always

Steps to Reproduce:
1.Block text
2.Release lh button (in preparation of pressing rh button to COPY)
3.Text unblocks

Actual Results:  
??  Can't copy text.

Expected Results:  
Blocked text should have remained blocked while I press rh button and select COPY.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 2

13 years ago
Copy and Paste - Bug in Firefox

(Different versions, different OS)

https://bugzilla.mozilla.org/show_bug.cgi?id=220900

Workaround not working for copy & paste - bug (In reply to comment #142)

*To run clipbrd.exe (Clipboard Viewer) does not solve the copy and paste
problem, neither does opening in a new window.
*Only workaround for me is to copy from one tab, paste in note/text/any-pad,
swich to the new pad, copy from anypad and paste it. This only works if I swich
windows before the second copy and paste, otherwise the clipboard is blank again
*argh*. Awful if you work with tabs, wikis or anything.
*Other workaround is to work with one instance of firefox and do all copy and
paste operations from or 2 opera...
*Drag and Drop sometimes works too...


Situation:

Copy and paste between different tabs or windows does not work at all (100%).
This problem does not affect other applications, just firefox. It seems that the
clipboard is deleted (for security reasons?!) when swiching from one tab/window
to another, but not when working with external programs...

System:

WinXP_Pro_SP1, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12)
Gecko/20050915 Firefox/1.0.7 (happened in the earlier version I had installed
2), Extensions: DOM Inspector, Wikipedia, Greasemonkey, CopyPlainText (tried is
as a solution for the copy and paste problem), RoboForm;

Unsuccessful tries:

1.Reinstalling after cleaning all data from previous installs
2.New User Profile
3.Open Clipboard
4.CopyPlainText (tried is as a solution for the copy and paste problem)
5.Work only with Firefox Windows, not with tabs
6.Upgrade to Firefox 1.0.7
7.Playing around with security settings

----

Suggested workarounds thus far (comment #142):
 
1. Open the current page in a new window (I usually just open any page in a new
window and check copy/paste there).

2. Start -> Run -> clipbrd.exe (Clipboard Viewer) 

3.Copy from one tab, paste in note/text/any-pad, swich to the new pad, copy from
anypad and paste it. This only works if I swich windows before the second copy
and paste, otherwise the clipboard is blank again 

4.Work with one instance of firefox and do all copy and paste operations from or
2 opera...

5.Drag and Drop sometimes works too...
Summary: Installed 1.0.2 and made Firefox default browser. Now cannot block and copy text. As soon as I release lh button, blocked text cancels. → Installed 1.0.2 and made Firefox default browser. Now cannot block and copy text. As soon as I release lh button, blocked text cancels.

Comment 3

12 years ago
bug 220900 is not related - in this bug, he doesn't get to the copy step because the text is not selected.

WFM  (note: reporter e-m address is bad)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.