Drop-down "select" boxes do not fire JavaScript 'onchange' event when changed with keyboard

RESOLVED DUPLICATE of bug 126379

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 126379
12 years ago
12 years ago

People

(Reporter: Ben Ryves, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

A select box in a form, when in focus, can not be changed with the mouse scroll
wheel like a normal Windows select box. However, you can change it with the
cursor keys. This does NOT fire a onchange event, even though the value in the
box has changed.

Reproducible: Always

Steps to Reproduce:
Create an HTML document with a select box. Stick
onchange="javascript:window.alert('boo!')" in the HTML. View the page. Go to the
box, change the value it shows. The alert pops up. Now, with it focussed, press
up and down on the keyboard.
Actual Results:  
Nothing.

Expected Results:  
It should have popped up an alert box.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.