If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TextField object in Java Applet on OSX grabs focus and wont let go

RESOLVED DUPLICATE of bug 247140

Status

()

Firefox
Keyboard Navigation
RESOLVED DUPLICATE of bug 247140
13 years ago
13 years ago

People

(Reporter: bex, Assigned: Aaron Leventhal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If you have an applet with a HTML form field and a Java form field, once you
click in the Java form field the focus goes into a black hole. It is no longer
possible to type anything into the browser anymore. 

Reproducible: Always

Steps to Reproduce:
1. go to the test web page
2. type something in the HTML field
3. type something in the Java field
4. click on the HTML field
5. type in the HTML field
Actual Results:  
the text keeps going into the Java field

Expected Results:  
the text should go into the HTML field

Its broken in Mozilla 1.7.6 as well. Its not a Apple JVM issue, because Safari
and IE 5.2 work fine.

Similar but different focus bugs: 266827, 217072, 66900, 53848

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 247140 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.