If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

gmail.com cannot place a cookies (cookies disabled, but gmail.com given an 'allow' exception).

RESOLVED INVALID

Status

()

Firefox
Preferences
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Michael R. Decker, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050226 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050226 Firefox/1.0.1

This may be a site specific problem, and not necessarily a Firefox issue, but
since it looks like an error in Firefox functinality, I shall post it here anyway.

I have disabled cookies, but have allowed certain sites with login and
preferences to set cookies via the 'exceptions' dialogue (eg. nytimes.com,
slashdot.org, mozilla.org).  This works on all sites but www.gmail.com.  Even
though I have allowed that site to set cookies via an exception, I still recieve
an error message from the site informing me that cookies must be enabled.  

Is this a problem with Firefox, or a problem with Gmail.  If it is a problem
with Gmail, let me know and I shall file a bug with them instead.

Reproducible: Always

Steps to Reproduce:
1.  Disable cookies by unchecking the 'allow sites to set cookies' in the
preferences dialog.
2.  Under 'exceptions,' add www.gmail.com and set to 'allow'
3.  Finally, try to log into gmail and 
Actual Results:  
Gmail reports that cookies must be enabled:  " Your browser's cookie
functionality is turned off. Please turn it on."

Expected Results:  
Gmail should have logged in and set whatever coookies it needed.

Comment 1

13 years ago
gmail.com does not set any cookies.  google.com, www.google.com, and
gmail.google.com, do.  Marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.