Closed Bug 288362 Opened 18 years ago Closed 18 years ago

Wiki: When viewing the block or deletion log an SQL error is generated

Categories

(mozilla.org Graveyard :: Server Operations, task, P2)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cso, Assigned: justdave)

References

()

Details

(Whiteboard: [blocker will fix])

When viewing the block log, an SQL error is generated as follows:

Database error
From MozillaWiki
A database query syntax error has occurred. This may indicate a bug in the
software. The last attempted database query was:

    SELECT log_type, log_action, log_timestamp, log_user, user_name,
log_namespace, log_title, cur_id, log_comment, log_params FROM `user`, `logging`
LEFT OUTER JOIN `cur` ON log_namespace=cur_namespace AND log_title=cur_title
WHERE user_id=log_user AND log_type='block' ORDER BY log_timestamp DESC LIMIT 0,50 

from within function "". MySQL returned error "1267: Illegal mix of collations
(latin1_swedish_ci,IMPLICIT) and (latin1_bin,IMPLICIT) for operation '=' (rodan)".
Summary: Wiki: When viewing the block log an SQL error is generated → Wiki: When viewing the block or deletion log an SQL error is generated
This is a known bug in 1.4rc1, it's fixed in 1.4 final.  Upgrading will fix it.
Depends on: wikiupgrade
OS: Windows XP → All
Priority: -- → P2
Hardware: PC → All
Whiteboard: [blocker will fix]
*** Bug 291173 has been marked as a duplicate of this bug. ***
This is fixed.  It was actually unrelated to the upgrades of mediawiki, but to
the upgrade from MySQL 4.0 to MySQL 4.1.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.