CSS with MEDIA attribute fails to import

VERIFIED DUPLICATE of bug 288360

Status

Camino Graveyard
Page Layout
--
major
VERIFIED DUPLICATE of bug 288360
13 years ago
12 years ago

People

(Reporter: Chris Lawson (gone), Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050330 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050330 Camino/0.8+

When CSS is either @import-ed or LINK HREF-ed with a MEDIA attribute in the
declaration, the browser fails to render the associated CSS.

If the MEDIA attribute is absent, it works fine. There's a prtety good
explanation of the problem here:

http://forums.mozillazine.org/viewtopic.php?t=243590

This is a very recent regression as it wasn't present in my own personal 29
March nightly build, but it cropped up in the 30 March build and has been
present through two builds this afternoon.

Reproducible: Always

Steps to Reproduce:
1. Go to a site that uses a MEDIA attribute in its CSS import declaration
2. Wonder why the CSS fails to load.
Actual Results:  
The CSS failed to load.

Expected Results:  
The CSS should have loaded.

Comment 1

13 years ago
This looks like a dupe (which was just fixed).

If not...feel free to un-dupe.

*** This bug has been marked as a duplicate of 288360 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
(Just checked the patch for the other bug; this is a dupe. Whew.)
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.