Image Blocking fails in 3-29 builds

VERIFIED FIXED

Status

()

Core
Image Blocking
--
major
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: stephend, Assigned: Michiel van Leeuwen (email: mvl+moz@))

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
I suspect bug 287628 broke Image Blocking by domain in Seamonkey, build
2005-03-30-06, Windows XP trunk.

Sites are correctly added to the Image Manager, and prefs seem to be correctly
selected/enabled (i.e. 'Block Images from this Site' is active in the menu item
for each site I visit which has an entry in the Image Manager), but the images
still display.

[02:58] <Matti> stephend: block images seems to work in my 0327 build. Could be
that fix from 0329
(Reporter)

Comment 1

13 years ago
Updating summary to reflect that since bug 287628 landed before the build
cutoff, which I believe is somewhere around 5 a.m., this really broke starting
with the 3-29 builds.
Summary: Image Blocking fails in post 3-29 builds → Image Blocking fails in 3-29 builds
(Assignee)

Comment 2

13 years ago
bug 279535 comment 14 kind of explains why perms.dll wasn't added to the
installer manifests. looks like i was wrong there.
*** Bug 281000 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

13 years ago
Flags: blocking1.8b2?
(Assignee)

Comment 4

13 years ago
Created attachment 179508 [details] [diff] [review]
possible patch

i can't test this patch, for the lack of a windows box. But i hope it will do
the trick. (I didn't add to this file initially, because i was confused that
libcookie.dll etc were not in there. Until i found out they are in the gre)
Attachment #179508 - Flags: superreview?(darin)
Attachment #179508 - Flags: review?(benjamin)

Comment 5

13 years ago
Comment on attachment 179508 [details] [diff] [review]
possible patch

r=me, no sr needed
Attachment #179508 - Flags: superreview?(darin)
Attachment #179508 - Flags: review?(benjamin)
Attachment #179508 - Flags: review+
(Assignee)

Comment 6

13 years ago
Patch checked in. However, i don't have a windows installer, so leaving this
open until someone can test if the bug is really fixed.
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> Patch checked in. However, i don't have a windows installer, so leaving this
> open until someone can test if the bug is really fixed.

I'll take care of that with tomorrow's build, and I'll let you know whether it's
fixed or not.
(Assignee)

Comment 8

13 years ago
I've heard it is indeed fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

13 years ago
Indeed it is.  Verified with build Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.8b2) Gecko/20050406 on Windows XP Seamonkey trunk.
Status: RESOLVED → VERIFIED

Updated

13 years ago
Flags: blocking1.8b2?
You need to log in before you can comment on or make changes to this bug.