All users were logged out of Bugzilla on October 13th, 2018

Sunbird 0.2 : I can't order the events in the events list

RESOLVED DUPLICATE of bug 278621

Status

RESOLVED DUPLICATE of bug 278621
14 years ago
13 years ago

People

(Reporter: marin, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

clicking on a column header in the events list of Sunbird
(calendar name, category, title etc.) 
doesn't order the events in the list.

however some re-ordering happends but I it seems not to be
related to the column I click.

Reproducible: Always

Steps to Reproduce:
1. Select a day that has events 
2. Click on a column header in events list (calendar name, category etc)
 

Actual Results:  
The events are reordered but it doesn't seem to be correct order

Expected Results:  
events must be ordered by the column u clicked (alphabeticaly or other way of
sorting)

Comment 1

14 years ago
Reporter:
    In general I'm unable to reproduce this bug as you describe it.  Can you
perhaps provide a bit more detail?  For instance, are there any columns that
definitely do or definitely do not sort correctly?  I would think that start/end
date would be the least like to sort incorrectly, but that is a pure guess. 
Something like name or category may be more likely to have an incorrect sort
mechanism.
(Reporter)

Comment 2

14 years ago
Do the following : 
add the column "Calendar" in the events view list
click on the header of the column ... 
events are sorted but it doesn't seem to be a 
alphabetical sort by the name of the calendar
this should be 100% reproducable

(In reply to comment #1)
> Reporter:
>     In general I'm unable to reproduce this bug as you describe it.  Can you
> perhaps provide a bit more detail?  For instance, are there any columns that
> definitely do or definitely do not sort correctly?  I would think that start/end
> date would be the least like to sort incorrectly, but that is a pure guess. 
> Something like name or category may be more likely to have an incorrect sort
> mechanism.

Comment 3

14 years ago
Thanks for the clarification, marin.  Please check out bug 278621, as this seems
to describe the problem you've outlined.  If you agree that it's the same issue,
can you please resolve this bug as a duplicate of bug 278621?
(Reporter)

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 278621 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.