Java applets in background tab "bleed" through to active tab and render in front of content

RESOLVED DUPLICATE of bug 162134

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 162134
13 years ago
13 years ago

People

(Reporter: Steve Kiehl, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5.7 (KHTML, like Gecko) Safari/125.12
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

After opening a new tab or switching to a different tab while visiting any other website that utilizes a 
java applet(s) to display animated content, Any updates to the java applet will essentially bleed through 
to the active tab. That is, they render in front of the content of the active tab despite the fact that the 
applet(s) is in an inactive tab.

Reproducible: Always

Steps to Reproduce:
1.  Open the browser and create a second tab.
2.  Visit any website (eg http://wordtracker.com) with the new tab.
3.  Wait for the applet to load
4.  Switch to any other tab (before or after applet loads)
5.  Once loaded, the java applet will reappear in the other active tabs.
Actual Results:  
The applets bleed through the tabs and cover up some or all of the content on the active tab depending 
on the size of the java applet.

Expected Results:  
The java applet should have continued running in the background without actually bleeding through to 
the active tabs.

I tried testing this on the 3/30 build, but the nightly build would not function and claimed to be 
missing an install file.  I then found that holding the option key down while starting firefox does not 
open the profile manager.  I browsed into the application folder (Firefox.app/Contents/MacOS) and ran 
'firefox' with the -profilemanager option and that worked fine.  I created a new profile and started it up 
and found that a new profile did not solve the problem.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 162134 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
*** Bug 288653 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.