new created profile may be lost in a certain exit sequence of mozilla instance

RESOLVED DUPLICATE of bug 151000

Status

SeaMonkey
Startup & Profiles
RESOLVED DUPLICATE of bug 151000
13 years ago
13 years ago

People

(Reporter: Nian Liu(n/a in a long time), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
1.start up a mozilla instance A
2.start up a mozilla instance B
3.create new profile in instance B
4.exit B
5.exit A

start mozilla.

expected result: profile created in instance B should be in profile list
actural result: profile created in instance B not there.

Comment 1

13 years ago
The profiles are listed in registry.dat, and profiles and registry.dat are
updated when you close mozilla. So if two instances of Mozilla open
registry.dat, modify it, and write it back, the last one closed wins.

some documentation about registry.dat, an editor, and profile-sharing:
http://www.geocities.com/stolenclover/backstage/moz-temp/registry.html
http://www.alain.knaff.lu/~aknaff/howto/MozillaCustomization/cgi/readMoz.cgi
http://www.mozilla.org/projects/embedding/profileSharing/

The bug I would this bug dupe to:
Bug 76431 Profiles need to be protected from running multiple instances of mozilla

But that wouldn´t prevent you running Netscape7 and Mozilla sametime, and doing
this, your problem is reproducable, as Netscape7 and Mozilla use one and the
same file registry.dat
Bug 186160 registry.dat written to default path instead of specified profile path

Another way to lose profile data, though I don´t know if this bug is fixed know
by roaming.

Bug 139562 profile settings gets lost after mozilla close- profiles stored on
network drives

Bug 151000 profiles disappear from the profile manager
if you lost a profile, but it is still on disk, you can restore it, see

Bug 151000  Comment #21 and Bug 151000  Comment #22

Comment 2

13 years ago
the steps in comment 0 are identical to the steps in bug 151000 comment 7

*** This bug has been marked as a duplicate of 151000 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.