If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Allow search from address bar and have second dropdown button for search plug-ins instead of separate search field

RESOLVED DUPLICATE of bug 242268

Status

()

Firefox
Search
--
enhancement
RESOLVED DUPLICATE of bug 242268
13 years ago
12 years ago

People

(Reporter: N. Welch, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910

Feature request:

Instead of having the separate search field with search engine dropdown, perhaps
it would be a better use of space to have simply a second button "search" next
to the "go" button and allow the user to enter their search in the address field
(as in Mozilla)... 

The search button could have a drop-down (similar to back/forward buttons) with
the various search engines where the icon of the selected engine would be
displayed next to the search button. If a search is conducted on keywords, then
the search button is changed, the search would be automatically conducted on the
newly selected search.

(As a longtime Mozilla user, I often find myself mistakely typing search terms
in Firefox's address bar only to have it go to the #1 website match on Google)

Reproducible: Always
Dupe of a WONTFIX.  Please search before filing.
Whiteboard: DUPEME

Comment 2

13 years ago
Duplicate of bug 242268?
(Reporter)

Comment 3

13 years ago
I did search - but searching for something and finding something are two
different things ;)

I read the comments on bug #242268 and must say I disagree strongly as many
probably would. I don't think it would complicate things for users at all and
using the address bar would provide more usable space...

Have the button actually say "search Google" or whatever is even much clearer
than  a nondescript icon and a tiny little box... 

Please reconsider adding it or offering it as an option. Thank you.
Whiteboard: DUPEME

Comment 4

13 years ago
I agree with N.Welch,
separate search field is good for some people, but for us old Mozilla users it
is very confusing to use other input field for searching. I removed search field
and changed search mode in the address field using tip:
http://www.mozilla.org/support/firefox/tips#beh_search
However when you enter just one word, the browser try to open it as URL. I would
like to see same behaviour as it is in Mozilla. It could be by default disabled.
Also I think that separate button for search is not necessary, using keyboard
down arrow key is enough.

Comment 5

13 years ago
It is much more ergonomic to have just one single line for entering addresses
and search terms than to have a seperate search box.
I prefer the way mozilla handles it over the seperate search box of firefox.
There could be a "start search with" dropdown button menu which allows users to
select the search functionality or it could be implemented like in mozilla, that
the search selection is implemented in the drop down list of the address bar.
I agree that novice users may find a seperate search box more intuitive but for
experienced users it is a step back in usability. It should at least be a
customizable feature to have the mozilla style.
 

*** This bug has been marked as a duplicate of 242268 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.