link <a =href\>...</a> does not work properly

RESOLVED DUPLICATE of bug 176312

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 176312
13 years ago
13 years ago

People

(Reporter: Mike Foster, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050325 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050325 Firefox/1.0.2

On the example site, there exists a link on the "legio draconis" image that
reads <a href=\> which shows up in Mozilla and Firefox as
http://www.legiodraconis.com/%5C when followed, but which is interpretted in IE
and Opera as http://www.legiodraconis.com/ 
As a result, the link is broken in Mozilla/Firefox browsers. I have alerted the
webmaster as to the problem, so there is a possibility this may be gone from the
site when you check for it.

Reproducible: Always

Steps to Reproduce:
1. create site with an <a href=\>
2. click on the link
3. observe the fact that the link does not work
Actual Results:  
browser steers to <web-root directory>/%5C

Expected Results:  
steer to <web-root directory>

Comment 1

13 years ago
IE assumes that \ is a typo for / and replaces it for you. Mozilla/Firefox don't.

*** This bug has been marked as a duplicate of 176312 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.