Cannot manually enter proxy port in preferences:general:connection settings (when instant apply is on)

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
--
major
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Alex Cline, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050308 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050308 Firefox/1.0+

When trying to manually enter the port for a proxy in the
preferences:general:connection settings, it does not remember the informaiton,
and instead I have to use about:config (which most people do not understand, but
will work nonetheless).

Reproducible: Always

Steps to Reproduce:
1.In the preferences:general dialog, go to connection settings
2.Choose "manual proxy configuration"
3.Enter a proxy's IP and the port
4.Say "OK" and close the preferences
Actual Results:  
Nothing. That is the problem. When I re-opened the dialog, the port was 0 again,
not 8118 as wished.

Expected Results:  
It should have kept the port as 8118 and then allowed me to use the proxy.

I did change my widgets with "Firefoxy", but that only changes the images in
there. I could get it to work by changing the options in about:config, but
normal users would probably appreciate using a preferences dialog.
(Reporter)

Comment 1

13 years ago
Uses changed widgets
Version: unspecified → 1.0 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050402
Firefox/1.0+
WFM
This happens when instant apply is on, which means it isn't (probably) mac-specific.
Severity: minor → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.1?
OS: MacOS X → All
Hardware: Macintosh → All
Summary: Cannot manually enter proxy port in preferences:general:connection settings → Cannot manually enter proxy port in preferences:general:connection settings (when instant apply is on)
Version: 1.0 Branch → Trunk
hmm, this isn't 100% reproduceable...
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> hmm, this isn't 100% reproduceable...

I was using a nightly build from March 8th. I am gonna try today's and see how
that is.
I can't reproduce in trunk win32 (April 02 build) with instantApply on.
I can't reproduce it anymore (20050507).
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Flags: blocking-aviary1.1?
Resolution: --- → WORKSFORME
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.