Mozilla crashes when trying to scroll this displayed pdf

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: John T, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050323
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050401

Using the nightly dated 4-1-2005, I've had crashes in several attempts to
display IRS forms in PDF format. I'm using Adobe Acrobat Reader 5.1, as versions
6+ insist on "calling home" instead of just displaying files. When reverting to
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050323, these crashes
don't occur.





Reproducible: Always

Steps to Reproduce:
1. Enter the above URL in the address bar or click on a link to it
2. Load the PDF file (using the Adobe Reader plugin) so the first page shows.
3. Attempt to scroll down to display the next page of the 2-page pdf.

Actual Results:  
Mozilla (or the plugin it called) crashes. 


Expected Results:  
Mozilla should have scrolled the pdf file to display the next page. 

Three times this happened and the Netscape problem reporter gathered information
for the incident report but could not send it. There was a "can't connect to
server" message as I recall. I don't know how to manually send crash data, and
deleted at least two queued crash reports. 

The crashes don't occur in the same place each time. acrord32.dll had one, and
gk???.??? in Mozilla had a couple.

Comment 1

13 years ago
(In reply to comment #0)

> Using the nightly dated 4-1-2005, I've had crashes in several attempts to
> display IRS forms in PDF format. I'm using Adobe Acrobat Reader 5.1, as versions
> 6+ insist on "calling home" instead of just displaying files. 

I removed all but two or three files from Adobe´s plugin directory, and it was
starting faster. Don´t know if it phones home, that computer is on a LAN.

When reverting to
> Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050323, these crashes
> don't occur.

So this regressed sometime between 20050323 and 20050401

If you download the file, (Right-click, Save as) and view it locally, do you
also get the crash?
 

> 
> Three times this happened and the Netscape problem reporter gathered information
> for the incident report but could not send it. There was a "can't connect to
> server" message as I recall. I don't know how to manually send crash data, and
> deleted at least two queued crash reports. 

The talkback agent couldn´t send, because either the server was down, or the
crash did some damages in your Win98, often it is working again after a reboot.
You don´t need to send manually, or delete the records, just close the talkback.
Next time you start Mozilla, Talkback will also be started and asks you, if it
should send the talkbacks waiting in the queue.
What I like about Talkback is you´re always asked, it never works without asking
you twice. If you want to send manually, open Talkback.exe in the
mozilla\components\ directory, click on 'Incidents' in the menu, and then you
can select 'Send queued Incident(s)   Ctrl+S', if there are unsent incidents.

When you have sent it, the server sents back a TalkbackID, and it is very
helpful, if the TalkbackID is posted here.
To get the TalkbackId(s), open Talkback.exe, select the lines you want to copy,
right-Click, Copy, and you´ve got all the TalkbackIDs to paste here.
If you just had a crash, don´t want to file a bug, it is helpful to write the
URL, fully or partially, into the URL field or comment field, so it can be
found, if you search at http://talkback-public.mozilla.org/talkback/fastfind.jsp
If you enter your TalkbackId there, you can see where it crashed, and follow
links right into the commented source code (right side) or query for bugs with
similar stacks (left side links). That is a valuable source to developers, if
there are some hints to reproduce.

I couldn´t test on this Win98 computer, as I don´t like the plugin, but download
the pdf and start acrobat 5.05.
(Reporter)

Comment 2

13 years ago
Where can I find the last week's worth of nightlies? I'm downloading the latest
and then will experiment a bit.
(Reporter)

Comment 3

13 years ago
Running (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050402, the pdf file loaded
and displayed with no problems. Strange. Earlier today, I downloaded this latest
nightly and the setup program reported that three xpi files in the archive were
bad. There may have been some sort of problem with the server or even Windows
that caused the problems today. I usually reboot for each session but the system
was up for a day or two when the problems occurred.

Between the Pope and the IRS, there may be extra traffic today too.



(Reporter)

Comment 4

13 years ago
Using Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050402, I loaded
the pdf with no problems. Besides the PDF problem, there was an apparent
download integrity problem the day this bug was filed. I don't see anything
wrong now.

Comment 5

13 years ago
resolving wfm according to comment 4 and own experience
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.