css2 doesnt handle linebreak correctly

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: hsz, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.5) Gecko/20050115 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.5) Gecko/20050115 Firefox/1.0

In the page http://hsz.tmp.hu/css_bug.html, the css "table" looks wrong.
It should looks like a table with 3 rows and 3 columns aligned to center.

w3c html and css validator say it is valid.

http://validator.w3.org/check?uri=http%3A%2F%2Fhsz.tmp.hu%2Fcss_bug.html
http://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Fhsz.tmp.hu%2Fcss_bug.html&usermedium=all

Reproducible: Always

Steps to Reproduce:
look the demonstrate url (http://hsz.tmp.hu/css_bug.html)
Actual Results:  
 1
 1
1 2
 2
2 3
 3
 3

Expected Results:  
1 2 3
1 2 3
1 2 3
I have no idea why you say it should look like a table, but the display looks
correct to me.  Note that the CSS inline box model computes the size of lines
based on 'line-height' and is not influenced by padding, border, or margin on
non-replaced inline elements.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.