Migrated profiles remigrate each launch.

VERIFIED FIXED in M14

Status

MailNews Core
Profile Migration
P3
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: laurel, Assigned: racham)

Tracking

({pp})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] Fix in hand)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Using 2000-02-22-11m14 mozilla build on linux rh6.0
Haven't yet migrated using current builds on mac, NT

Every time I launch, my migrated profile remigrates without having removed files
or registry.

1.  You have a 4.x profile
2.  Remove mozregistry and any lingering 5.0 user files.
3.  Launch mozilla -profilemanager
4.  Select the 4.x profile to migrate, click Start Mozilla button. Wait for
migration to complete. Go to mail, login and open the migrated profile's inbox.
5.  Quit.
6.  Launch mozilla -profilemanager. Select the same profile you just migrated
and click Start Mozilla button in profilemanager.

Result:  migration progress dialog appears, profile goes through remigration
process (or appears to).

Expected:  should only see migration dialog once.
(Reporter)

Updated

19 years ago
Severity: normal → major
(Reporter)

Comment 1

19 years ago
Doesn't happen using NT.
Having mac problems...

marking pp in keywords field
Keywords: pp
I'm seeing this too.

this is a bug for racham.
Assignee: sspitzer → racham
Keywords: beta1
Target Milestone: M14

Comment 3

19 years ago
see also bug 27861
(Reporter)

Comment 4

19 years ago
I just switched to the feb22 commercial build, removed files/registry and tried
again.  Now I'm getting behavior as grace described in bug # 27861, where the
migrated profile won't relaunch.
(Assignee)

Comment 5

19 years ago
Need to check why is this happening on Linux & Mac. Don't see it on Windows.
Status: NEW → ASSIGNED

Comment 6

19 years ago
[PDT+]

Updated

19 years ago
Whiteboard: [PDT+]
(Assignee)

Comment 7

19 years ago
I have fix for this. Tested  it on Linux. Need to check on other platforms. 
Whiteboard: [PDT+] → [PDT+] Fix in hand
adding shaver.  

he's dying for the fix.
(Assignee)

Comment 9

19 years ago
Registry entries were missing at the end of the session. That is causing this 
behavior to show up. Dan Veditz looking if there are any nsRegistry issues that 
are causing this. My fix was kind of work around for the problem. Creating an 
attachment (diffs) that solved problem for me. But we are now looking to see if 
we can attack this from registry side. Adding dan to cc list.
(Assignee)

Comment 10

19 years ago
Created attachment 5725 [details] [diff] [review]
patches to nsProfile.cpp and nsProfileAccess.cpp
(Assignee)

Comment 11

19 years ago

*** This bug has been marked as a duplicate of 28243 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 12

19 years ago
verified
Status: RESOLVED → VERIFIED
How was this fixed without the change to prevent xpinstall from linking in an 
extra copy of libreg on Unix?
(Assignee)

Comment 14

19 years ago
Originally I had a patch, that used to build the lost registry tree. But that 
was not the right way to go as we discovered there is problem with linkage on 
Linux. With the fix you put in for Makefile yesterday solves this problem as the 
profile information remains intact. So, this is marked as dup of 28243. Marked 
fixed as a dup.

Comment 15

19 years ago
reopening per dveditz
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 16

19 years ago
marking FIXED per dveditz
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 17

19 years ago
build 2000022808
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.