textarea shows remainder of page and never closes.

RESOLVED DUPLICATE of bug 227358

Status

()

Toolkit
Form Manager
--
critical
RESOLVED DUPLICATE of bug 227358
13 years ago
9 years ago

People

(Reporter: steffan, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I am replicating the website http://pastebin.com. It is written in php but I am
writing it in Lasso. Funny thing is this. If the only code given is (rendered)
<textarea ....><?LassoScript</textarea> but no closing ?> is given when the form
is filled in when served it will ignore the closing </textarea> and keep going
enclosing the rest of the page in the form field. This does not occur in Safari
or Mac IE. This is visible here : http://www.lassoforge.com/lassobin.lasso?ID=3
Screen shots avaible upon request if the code is missing. This page is still in
test status.

Reproducible: Always

Steps to Reproduce:
Design a form and have this :
<textarea ......><?LassoScript</textarea> more html here and so on
Actual Results:  
you get the rest of the page after <?LassoScript crammed into the text area.

Expected Results:  
It should have shown a text area with <?LassoScript only in it as this is what
ALL other browsers are doing.

Comment 1

13 years ago
It seems a bug in LassoScript to me. LassoScript should return fatal error as
the document is not well formatted.
Summary: textarea shows remainder of page and never closes. → textarea shows remainder of page and never closes.

Comment 2

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050227
Firefox/1.0+

Your code seems to WFM.

The relevant part of your source goes:

<td valign="top" align="left"><textarea name="code" cols="80" rows="10"
style="font-size: 12px; font-family: Courier;">&lt;?LassoScript</textarea></td>

What were you expecting?

You might want to check that the problem is reproducible on a more recent 
version of Firefox.
(Reporter)

Comment 3

13 years ago
Created attachment 179467 [details]
This is a screen shot of what the code does when the values are not html encoded.

I received an email from the person the bug was assigned to regarding the
appearance that the bug was not verifiable. I had since reporting the bug
changed the code to html encode the data from the database as it is put in
there. This gives the appearance that the bug is fixed but it is not. If you
physically make a test page and put in the code <textarea
....><?LassoScript</textarea> you will see that FF ignores the last </textarea>
and shows the remainder of the code. The attached screenshot shows what happens
with that code.

Comment 4

13 years ago
If you have a better testcase, please attach it to the Report.

I don't see why Firefox should see a <?LassoScript ... ?> tag at all. If such a 
tag were present in your source, I would have expected the server to hand it off 
to the Lasso interpreter, and replace the tag with the return from Lasso.

Alternatively, why do think that the Firefox is wrong to keep the <textarea>
element open until the <?LassoScript ... ?> tag is closed?
(Reporter)

Comment 5

13 years ago
In reply to the email below:

Did you see the screen shot? While I know that it is no standard to have that kind of code in there, but, 
none the less it will happen. It has happened. It threw several people for a loop trying to figure it out 
that this was a bug in FireFox. None of the other major browsers interpret that code in there the same 
way. Shouldn't a web browser be able to have ANYTHING inside of a text area? This is for a code sharing 
site. It wouldn't be appropriate of me to say that "FireFox Users : If you see a bunch of garbage in the 
text area just copy what is pertinent. The rest is a bug in FireFox." 

I would never do this but still. It is a bug. Have you seen the screen shot? Have you tested it in other 
browsers?

Does this mean that you are not accepting this as a bug?

> If you have a better testcase, please attach it to the Report.
There will be many more like this where programming code is pasted in there. Shall I submit the same 
bug repeatedly ONLY for FireFox each time the browser reacts this way? 
> I don't see why Firefox should see a <?LassoScript ... ?> tag at all. If such 
> a 
> tag were present in your source, I would have expected the server to hand it 
> off 
> to the Lasso interpreter, and replace the tag with the return from Lasso.
Again, if you looked at the context of the page it is for code sharing. Lasso should not interpret the 
code because if it did, you'd never be able to see it. That defeats the purpose of a code sharing site. I 
would be then allowing anyone to execute live Lasso code on my server for anyone. That would not be 
too good, would it?
> Alternatively, why do think that the Firefox is wrong to keep the <textarea>
> element open until the <?LassoScript ... ?> tag is closed?
Because it is within a text area. The design of the site is to display code and not have it executed. It is 
intentionally shared this way. 


I don't mean to come off as sarcastic here. I apologize if I do but this is clearly misinterpreted code at 
the fault of FireFox. 

Shall I get a significant number of people to submit the same bug so that you can see it is a matter of a 
BUG and not a simple misunderstanding of the way that FireFox interprets code?

Thanks

Steffan


> From: bugzilla-daemon@mozilla.org
> Date: Sun, 3 Apr 2005 09:59:55 -0700
> To: steffan@hldns.com
> Subject: [Bug 288820] textarea shows remainder of page and never closes.
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=288820
> 
> 
> 
> 
> 
> ------- Additional Comments From bfowler@ewitness.co.uk  2005-04-03 09:59 PST 
> -------
> If you have a better testcase, please attach it to the Report.
> 
> I don't see why Firefox should see a <?LassoScript ... ?> tag at all. If such 
> a 
> tag were present in your source, I would have expected the server to hand it 
> off 
> to the Lasso interpreter, and replace the tag with the return from Lasso.
> 
> Alternatively, why do think that the Firefox is wrong to keep the <textarea>
> element open until the <?LassoScript ... ?> tag is closed?
> 
> 
> -- 
> Configure bugmail: https://bugzilla.mozilla.org/userprefs.cgi?tab=email

Comment 6

13 years ago
Created attachment 179489 [details]
test case

Test the reporter describes

Comment 7

13 years ago
Reproduces in Firefox 1.0
WFM in Firefox 20050324 so it has been fixed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 8

13 years ago
Reopening for right resolution
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 9

13 years ago

*** This bug has been marked as a duplicate of 227358 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Why did you reopen this bug?  The bug is fixed on trunk, and Firefox 1.1 will
not show this problem.  Firefox 1.0.x will continue to handle this case
properly/badly depending on your perspective on how we should handle quirks mode.

If you believe this is an error, please email me with concerns, do not touch the
bug.

*** This bug has been marked as a duplicate of 227358 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.