Closed Bug 288831 Opened 15 years ago Closed 15 years ago

news.bbc.co.uk hangs firefox

Categories

(Core :: DOM: Editor, defect, blocker)

x86
Windows 2000
defect
Not set
blocker

Tracking

()

VERIFIED FIXED

People

(Reporter: stevee, Assigned: smontagu)

References

()

Details

(Keywords: hang, memory-leak, regression)

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050403
Firefox/1.0+
Firefox.exe CREATION 03 April 2005, 03:44:36

1. Go to http://news.bbc.co.uk
2. Observe firefox hangs. Usually with 'newsimg.bbc.co.uk' in the status bar

Doesn't hang with official Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.8b2) Gecko/20050402 Firefox/1.0+ build
kw > hang, regression
Keywords: hang, regression
->Blocker
->mlk

Haven't tried with FF1.0.3 but I assume it's the same
reproducable on many sites including Gmail

regressed after bug 288818 landed

CC Brendan
Severity: critical → blocker
Keywords: mlk
?1.0.3 (it's cfmd on aviary too)
?1.1
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.0.3?
Gmail repro:
1.open FF
2.go to gmail inbox
3.label a large file and press archive
4.freeze
Assignee: firefox → general
Component: General → JavaScript Engine
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.1+
Flags: blocking-aviary1.0.3?
Flags: blocking-aviary1.0.3+
Product: Firefox → Core
QA Contact: general → general
I've backed out the patch from bug 288137. After that, I don't see the bug
anymore in my debug build. 
Blocks: 288137
(In reply to comment #3)
> ?1.0.3 (it's cfmd on aviary too)
> ?1.1

(In reply to comment #3)
>I've backed out the patch from bug 288137. After that, I don't see the bug
>anymore in my debug build.

Bah, I misread a comment, does NOT happen on Aviary.
bug 288137 was not checked in on Aviary either
+1.0.3 can be remove (and +1.7.7 aswell I suppose)
The gmail hang is definitely bug 288137.  Is the news.bbc.co.uk hang as well?
(FWIW, I couldn't reproduce the news.bbc.co.uk hang, but I could repro the gmail
hang, and it was in the function smontagu modified.)
Flags: blocking1.8b2+
Assignee: general → mozeditor
Component: JavaScript Engine → Editor
Flags: blocking1.7.7+
Flags: blocking-aviary1.0.3+
QA Contact: general → bugzilla
Assignee: mozeditor → smontagu
(The function in nsHTMLContentSerializer, that is.)
Are you all testing on depend builds? I discovered testing bug 210501 that
unicharutil still has dependency issues.
(In reply to comment #8)
> (FWIW, I couldn't reproduce the news.bbc.co.uk hang, but I could repro the gmail

I have Adblock disabled
Cookies blocked
popups blocked

Opening http://news.bbc.co.uk freezes FF before rendering anything

I think I have a handle on this.
Status: NEW → ASSIGNED
Attached patch patchSplinter Review
Doh! In some code paths I never set lengthReplaced so advanceLength wasn't
getting incremented.
Attachment #179481 - Flags: superreview?(dbaron)
Attachment #179481 - Flags: review?(dbaron)
Attachment #179481 - Flags: superreview?(dbaron)
Attachment #179481 - Flags: superreview+
Attachment #179481 - Flags: review?(dbaron)
Attachment #179481 - Flags: review+
Checked in
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050403
Firefox/1.0+ 12:30 PDT build

Gmail and BCC both work again with no extra mem usage

->Verified

Thanks for the quick fix
Status: RESOLVED → VERIFIED
*** Bug 288905 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.