Last Comment Bug 288856 - do not show any religious content on mozilla.org and its subdomains (e.g. planet.mozilla.org)
: do not show any religious content on mozilla.org and its subdomains (e.g. pla...
Status: RESOLVED WONTFIX
:
Product: mozilla.org
Classification: Other
Component: Governance (show other bugs)
: other
: All All
: -- enhancement (vote)
: ---
Assigned To: Zak Greant
:
:
Mentors:
http://planet.mozilla.org
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-03 10:05 PDT by Mathieu Pellerin
Modified: 2011-08-05 21:11 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Mathieu Pellerin 2005-04-03 10:05:16 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050402 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050402 Firefox/1.0+

On the domain/sub domains of Mozilla.org, planet.mozilla.org being the
particular case that raised this bug, you should not see some big-fan of X Y or
Z religion making claims/thesis/revelations/whatever-you-want-to-call-it on his
path to enlightenment, it's just not appropriate, not helping the image of the
products your trying to push to the mass, might be offensive to users and
potential users, etc.

Something should be quickly done for planet.mozilla.org, and some thoughts
should be given to other parts of mozilla.org. Stop showing articles on
religious matters (that can be easily done by filtering in which category the
article is placed on the owner's blog site) and make a policy out of it.

Reproducible: Always

Steps to Reproduce:
1.Go to planet.mozilla.org regularely

Actual Results:  
Sometimes you see some unappropriate article on god and creationism...?!?

Expected Results:  
Filtered out potentially offending material.
Comment 1 William Price 2005-04-07 23:52:12 PDT
(In reply to comment #0)
> On the domain/sub domains of Mozilla.org, planet.mozilla.org being the
> particular case that raised this bug, you should not see some big-fan of X Y or
> Z religion making claims/thesis/revelations/whatever-you-want-to-call-it on his
> path to enlightenment, it's just not appropriate, not helping the image of the
> products your trying to push to the mass, might be offensive to users and
> potential users, etc.

I hate to use AOL as an example, but I suppose you've e-mailed that company to
complain about any/all spiritual content found on any of ITS subdomains (i.e.
users' homepages).

I see you use gmail.  Would you be surprised that Google offers a Usenet
(newsgroup) browsing service (groups-beta.google.com) that lets you browse,
among other things, many discussions on various religious views?  Have you
pestered them as well?


> Actual Results:  
> Sometimes you see some unappropriate article on god and creationism...?!?

Ahh, but that depends on what an individual feels is "unappropriate" or not,
doesn't it?  I don't agree with your views, but I respect your opinion and your
right to believe as you do.  The Mozilla Foundation supports "free software" and
I would wager they support free speech as well (religion included).

No one's forcing you to go to planet.mozilla.org and read the occasional
religious post made by an individual (not speaking for the Foundataion).  Even
if you do come across one, no one is forcing you to accept their viewpoint, or
even continue reading the particular article.  Simply browse elsewhere if it
matters that much to you.

Besides, one could claim that your complaint is offensive by the same logic. 
Does that mean Bugzilla should be shut down?  No.  You're holding the Mozilla
Foundation to a higher, double standard.  Work on accepting the fact that people
will have, and share, different opinions about many subjects.

Bugzilla isn't a discussion forum, so this will be the last of it from me.
Strongly suggesting WONTFIX INVALID, and I'd make the change if I could.
Comment 2 Mathieu Pellerin 2005-04-08 01:10:10 PDT
err, you didn't get my point, otherwise you wouldn't have compared my claim with
AOL user pages or Google :).

Furthermore, I don't think ppl working on moz products shouldn't have the right
to free speech. This bug is about the relevance religious posts and the
goods/arms it can do to the Mozilla Foundation when they show up on their domain.

You seem to think it doesn't do any bad to the "image" of MoFo while I think it
might be the opposite.

I don't care if the programmers/thinkers working to improve mozilla products
blog about their beliefs, but imo it's inappropriate to show their religious
inspirations on a mozilla.org subdomain, on a portal to articles about web
standards and gecko development. I don't have any problem though if they show up
on feedhouse.mozillazine.org.

Like you pointed out, bugzilla is not a forum; I filled this bug to try to
improve something that will, again that's my opinion, help the MoFo goal to
reach as many people as they can with their products.
Comment 3 Prognathous 2005-06-20 01:38:27 PDT
Just like Asa Dotzler deemed his blog as inappropriate for planet.mozilla.org
due to additional content about cats and astronomy, the same logic should apply
to other blogs. pmo is a Mozilla-oriented blog, let's keep it this way.

Confirming bug.

Prog.
Comment 4 Reed Loden [:reed] (use needinfo?) 2006-02-13 13:58:36 PST
--> Governance, though Websites :: planet.mozilla.org is where this bug would go for other issues. However, since it is policy related, I'll let Governance decide.
Comment 5 Reed Loden [:reed] (use needinfo?) 2006-03-15 22:11:29 PST
zak: Please only change the assignee and not the QAContact when you are taking a bug. Many of us watch the QAContact for changes with Governance bugs, and by changing it, it causes bugmail to be lost and never seen. Thanks!
Comment 6 Zak Greant 2006-05-30 07:21:10 PDT
The abstract questions seem to be this:
* Should off-topic content be aggregrated on planet.mozilla.org?
* Who decides when something becomes off-topic?

The tasks to do here are:
* contact the Planet Mozilla maintainer and request any relevant guidelines
* find out the goals for Planet Mozilla, getting group input, if needed
* if needed, write and enforce guidelines
Comment 7 Cameron 2007-03-09 09:31:14 PST
CCing new planet module owner and peers.
Comment 8 Gervase Markham [:gerv] 2007-03-09 09:40:28 PST
Planet policy is currently being hashed out in the mozilla.governance newsgroup. I suggest anyone interested join the discussion there. Once it's decided, this bug can be closed.

Gerv
Comment 9 Asa Dotzler [:asa] 2007-03-09 09:54:33 PST
Planet Mozilla is an aggregation of the blogs of Mozilla community members. The focus is the _people_ of Mozilla and the feeds aren't going to be censored by the Planet Mozilla maintainers. If feed contributors want to offer Mozilla(product/project) only feeds, that's up to them but it absolutely not going to be a requirement. 

I'll be posting a second draft of the policy for Planet Mozilla management to the mozilla.governance group once we get some basic housekeeping taken care of. This bug, though, is not going to be fixed since it would require that either the Planet Mozilla maintainers censor posts or require that contributors self-censor. Neither of those is going to happen under my watch. 
Comment 10 Asa Dotzler [:asa] 2007-03-09 09:56:34 PST
Oh, and I forgot to note the "other mozilla domains" bit here. I don't think we're going to build content filters into our CMS (if one can call it that) any time soon. If there are individual cases of problem pages, please file individual bugs which will be discussed on the merits of that particular case. 
Comment 11 Eric Shepherd [:sheppy] 2007-03-09 10:26:48 PST
I was specifically told when my blog was added to Planet that it wouldn't be accepted unless I offered a Mozilla-only RSS feed, which I did.  I was a little surprised since you see non-Mozilla content on Planet all the time, but whatever...
Comment 12 Gervase Markham [:gerv] 2007-03-09 10:34:56 PST
sheppy: there's been a change of policy. See the mozilla.governance newsgroup for more details.

Gerv
Comment 13 Eric Shepherd [:sheppy] 2007-03-09 10:38:59 PST
Thanks, yeah, I'd heard something about that but to be honest it's not that big a deal to me.  I don't post much non-Mozilla stuff on my blog anyway. :)
Comment 14 Asa Dotzler [:asa] 2007-03-09 10:41:10 PST
Eric, if you'd like to add a full feed to Planet instead of a censored feed, please file a bug and we'll make the change. 

Note You need to log in before you can comment on or make changes to this bug.