Using (") quotes on style definition on colour defintion causes firefox to ignore it

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: delcypher, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2

In Internet explorer the  functions A:link, A:visted, A:active, A:hover, in
firefox they do not: this is the code in the <head>

<style type="text/css">
body {  text-decoration: none;
            color: "#000000";
            font-family: "verdana";
            font-size: 8pt;}
A:link {text-decoration: none ; color: "#FFFFFF"; font-size: 8pt;}
A:visited {text-decoration: none; color: "#FFFFFF"; font-size: 8pt;}
A:active {text-decoration: none; color: "#FFFFFF"; font-size: 8pt;}
A:hover {text-decoration: none; color: red; font-size: 8pt;}
</style>

To make these style settings come into affect in firefox the "#FFFFFF" must be
changed to #FFFFFF (basically removing the double quotation marks). Under IE
this isn't neccessary


Reproducible: Always

Steps to Reproduce:
1.Create to different pages with the style settings i specified in details
2. Try with color: #FFFFFF with quotation marks


Actual Results:  
Ignores colour setting

Expected Results:  
set the colour to #FFFFFF
(Reporter)

Comment 1

14 years ago
Mistake on reproducing steps, should be
1.Create html page with the style settings i specified in details
2. Try with color: #FFFFFF with quotation marks

also, works fine for body {}, but not for A:

Comment 2

14 years ago
Quotes are not part of a color. See http://www.w3.org/TR/CSS1#color-units for
the definition.

I can't reproduce any differences as described between body and A:link for how
they handle quotes.

Comment 3

14 years ago
Its ignoring it since its invalid, see comment 2

--> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.