event end datetime displayed incorrectly in event list (unifinder) [trunk]

RESOLVED FIXED

Status

Calendar
Sunbird Only
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: gekacheka, Assigned: Mostafa Hosseini)

Tracking

({regression})

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: trunk

event end datetime displayed incorrectly in event list (unifinder).

Problem is in unifinder.js -- erroneously adding the duration to the end
datetime (previously added duration to next occurrence *start* datetime, but
currently does not look for next occurrence so uses the bare end datetime).

Reproducible: Always

Steps to Reproduce:
1.  Create an event of non-zero duration (end later than start).
2.  Make sure end date column is visible in event list.

Actual Results:  
End datetime shown is long after actual end datetime (edit event to bring up
event dialog)

Expected Results:  
End datetime shown in table is same as actual end datetime.
(Reporter)

Updated

14 years ago
Keywords: regression
(Reporter)

Comment 1

14 years ago
Created attachment 179549 [details] [diff] [review]
unifinder.js patch: comment out addition of duration since not adding to start of occurence

(patch -l -p 2 -i file.patch)

Since eventEndDate is initially the end date rather than the start of the next
occurrence, this patch just comments out the code that adds the event duration
to it.

(It looks like getNextOccurrence is not yet implemented, so it is not possible
to fix this for reccurrences yet.  It is defined to return calIItemOccurrence,
but that interface doesn't seem to be defined.
http://lxr.mozilla.org/seamonkey/source/calendar/base/public/calIRecurrenceInfo.idl#88


Also need getPreviousOccurrence (or getLastOccurrence), to be able to show the
times of the last occurrence if now is after the last occurrence.)
Attachment #179549 - Flags: first-review?
i don't think this is the right fix. We should fig bug 285033 and then look for
the right thing here.
Depends on: 285033
Comment on attachment 179549 [details] [diff] [review]
unifinder.js patch: comment out addition of duration since not adding to start of occurence

(requesting review from nobody isn't the fastest way to get review...)
this is now fixed with bug 286070.
Attachment #179549 - Attachment is obsolete: true
Attachment #179549 - Flags: first-review?

Updated

13 years ago
Blocks: 298936
Resolving for real now.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.