Download fails if file size is near 5 gb

RESOLVED DUPLICATE of bug 184452

Status

()

Core
Networking
--
major
RESOLVED DUPLICATE of bug 184452
13 years ago
13 years ago

People

(Reporter: Antti Mattila, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

When starting download for a file that is for example 5gb, download manager
shows the file size incorrecly (sometimes 300mb etc), and it downloads only
first 300 mb  of that file. 

I assume that there is a 32bi variable used for the "content-length" header, and
it goes over.

Reproducible: Always

Steps to Reproduce:
1. Make a file over 5gb
2. Try to download it
3. Check that the downloaded file size is the sam

Actual Results:  
File was download was incomplete.

Expected Results:  
Download the file correctly and display the correct file size in download manager

Comment 1

13 years ago
If you go over 2GB, you have bug 228968 (negative file sizes). To fix that we
need to go to 64-bit counters, which will fix this bug too.

Reporter, are you asure that the download actually *stopped* after 300 MB ?
(never mind the incorrect counters). That hasn't been seen before.
Summary: Download fails if file size is near 5 gb → Download fails if file size is near 5 gb

Comment 2

13 years ago
Does the download really fail or does just not show ?

*** This bug has been marked as a duplicate of 184452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

13 years ago
Yes, it actually stops the download at 360mb and the file is un-usable. File
that I'm downloading is 4554904 kb of size. 
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

13 years ago
This still makes this bug a duplicate of 184452. Nothing new.

*** This bug has been marked as a duplicate of 184452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Component: Download Manager → Networking
Product: Firefox → Core
Resolution: --- → DUPLICATE
Version: unspecified → Trunk

Updated

13 years ago
OS: Windows XP → All
Hardware: PC → All
You need to log in before you can comment on or make changes to this bug.