clicking links in client-side image maps scrolls the page to the bottom of the imagemap, making it impossible to click some imagemap links

VERIFIED FIXED in mozilla1.8.1

Status

()

Core
Event Handling
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: Jan Darmochwal, Unassigned)

Tracking

(4 keywords)

Trunk
mozilla1.8.1
regression, testcase, verified1.8.0.1, verified1.8.1
Points:
---
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050402
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050402

A large image with an image map is inside <a>-tags like this:
   <a href="blah"><img src="image" usemap="map"></a>
(This is probably not good style, but I haven't found anything in the html specs
forbidding it and validator.w3c.org does not complain.)

If you click one of the image map's links, there are two possible cases:
  1) the bottom of the image is on your screen:
    The browser will follow the link.
  2) the bottom of the image is not on your screen:
    The browser will jump to the bottom of the image.

This makes it impossible to follow links at the top of large images.

The jumping behaviour also occurs if there is an image (with no image map)
inside <a>-tags, but the browser will follow the link anyway.


Reproducible: Always

Steps to Reproduce:
1. click the "button" in the testcase

Actual Results:  
Mozilla jumps to the bottom of the image.


Expected Results:  
Mozilla follows the button's link.


This bug is related to bug 105894 (fixing bug 105894 would probably fix this one
as well), but it does not depend on it.

This is a Seamonkey only problem, works for me with Firefox 1.0.2.
(Reporter)

Comment 1

12 years ago
Created attachment 179561 [details]
large image required by testcase
(Reporter)

Comment 2

12 years ago
Created attachment 179563 [details]
testcase

Updated

12 years ago
Depends on: 105894

Comment 3

12 years ago
Created attachment 180900 [details]
Testcase without link around image

This is almost the same testcase as attachment 179563 [details] except that there is no
extra double quote character and the image is not embedded within a link.

Comment 4

12 years ago
Created attachment 180902 [details]
Testcase without link around image

This is almost the same testcase as attachment 179563 [details] except that there is no
extra double quote character and the image is not embedded within a link.
(Sorry, about previous comment and previous testcase: I forgot to select type
of attachment)
Attachment #180900 - Attachment is obsolete: true
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Updated

12 years ago
Flags: blocking1.8b4?

Updated

12 years ago
Flags: blocking1.8b4? → blocking1.8b4-

Comment 5

12 years ago
*** Bug 306203 has been marked as a duplicate of this bug. ***

Comment 6

12 years ago
*** Bug 295545 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Summary: clicking links in client-side image maps scrolls the page → clicking links in client-side image maps scrolls the page to the bottom of the imagemap, making it impossible to click some imagemap links

Updated

12 years ago
Keywords: testcase
*** Bug 307727 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
Not just a Seamonkey bug...

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-CA; rv:1.8b4) Gecko/20050908 Firefox/1.4

(FF 1.5 beta 1)
fixed by bug 105894.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9alpha

Comment 10

12 years ago
*** Bug 317438 has been marked as a duplicate of this bug. ***
*** Bug 318757 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Keywords: regression
*** Bug 318757 has been marked as a duplicate of this bug. ***
*** Bug 321677 has been marked as a duplicate of this bug. ***
Keywords: fixed1.8.1
Target Milestone: mozilla1.9alpha → mozilla1.8.1
Keywords: fixed1.8.0.1

Comment 14

12 years ago
v.fixed on 1.8.0.1 with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1 with testcase in comment #4, click on image takes you to link page.
Keywords: fixed1.8.0.1 → verified1.8.0.1
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1 → verified1.8.1
You need to log in before you can comment on or make changes to this bug.