transparant flash covers html actions and more problems

RESOLVED DUPLICATE of bug 259716

Status

()

Core
Layout
--
minor
RESOLVED DUPLICATE of bug 259716
13 years ago
12 years ago

People

(Reporter: robert, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2

First, excuse my poor english lanquage skills..bare with me.

I have a flash menu (with animations) in a layer on top of several embedded 
iframes (with plain html AND flash). The buttons to initiate the animations 
work great but somehow the sub-menu buttons lose there clickability (this only 
happens when wmode is transparant!?). please check the example for a 
demonstration. Also, underlaying imagemaps and a hrefs are show but you can not 
click them? 

Important to know is that in the final frame of the flash-animation there is NO 
image of graphic covering the page (set to 0% alpha for example). I use a empty 
stage only with buttons on top.

Please note the sit is in creation so it is full of other bugs and bad 
code...ignore it :)

Thanks
Robert

Reproducible: Always

Steps to Reproduce:
1.create flashmenu with transparant window mode on top of plain flash
2.play animation or whatever so that submenus appear OVER the html
3.Notice that submenubuttons dont work and underlaying html does not work

Actual Results:  
-submenu buttons do not work (clickability gets lost)
-underlaying html is not clickable

Expected Results:  
Similar to Internet explorer it should have a great big rectangle over the 
different shapes in the submenu; wich are clickable. Also, the underlaying html-
actions (a href etc.) should be clickable. Check the example: 
www.digilemma.nl/ellen/index.html

Updated

13 years ago
Assignee: general → firefox
Component: Bugzilla-General → General
Product: Bugzilla → Firefox
QA Contact: default-qa → general

Comment 1

13 years ago
I confirm this in Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.6)
Gecko/20050318 Firefox/1.0.2
Severity: major → minor
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Product: Firefox → Core
Version: unspecified → Trunk

Comment 2

13 years ago
See Bug 102695 '[EVENTTARG]Treat some transparent elements as "transparent 
to events"'

See Bug 102695 Comment 30 .

There are probably other bugs that cover this issue. So far as I can tell, 
there is no standard that mandates certain behaviour in this situation, but
it appears that the Mozilla team in the past has consistently said that 
event propogation is based on z-ordering and not opacity.

If you think that the frontmost object is not receiving clicks, you may
want to submit a shorter testcase. 

See 
Bug 133968 "Flash plugin and z-index bug"
Bug 238668 "Flash animation always in front of dynamic layers"
(Reporter)

Comment 3

13 years ago
@Ben Fowler: Note that the transparancy feature work great, no problem there!
But when I turn the Wmode=transparant OFF the buttons in the submenu work just 
fine...somehow with the transparancy ON, the buttons simple dissapear! I think 
that counts as a bug. I dont know what you mean when you say there is no 
standard that mandates certain behaviour? Please explain it to me if you can be 
so kind...

BUT, there is something else: when you click "grafisch" there will be a very 
random changing of the mouse when hovering above buttons like "websites" 
and "tijdschriften" (thus indicating a link). If you click very fast (several 
times) then the link WILL work but the target destination is wrong?! A 
different page is being loaded than I'm calling from within flash; wich I find 
very weird. 

Thanks for the comments guys
Robert

Comment 4

13 years ago
(In reply to comment #3)
> But when I turn the Wmode=transparant OFF the buttons in the submenu work just 
> fine...somehow with the transparancy ON, the buttons simple dissappear! 

I may be wrong, but when you set transparent OFF, aren't you just telling
that swf to paint above everything else: Bug 93959 Comment 59 .

> I dont know what you mean when you say there is no 
> standard that mandates certain behaviour? Please explain it to me if you can 
> be so kind...

Bug 88866 "transparency and links inconsistency"
Bug 102695 Comment 19 (and others)
Bug 12232 "[EVENTTARG] events going to wrong element"

If your problem is a duplicate of something already in bugzilla, it would
be a better use of your time to read existing comments rather than try
to get people to comment here.
(Reporter)

Comment 5

13 years ago
"I may be wrong, but when you set transparent OFF, aren't you just telling
that swf to paint above everything else"

Offcouse this true concerning the html content underneath but the submenu 
buttons are on the top layer of the flash (swf). So I dont understand why 
Firefox is deleting them when transparancy is off.

"If your problem is a duplicate of something already in bugzilla, it would
be a better use of your time to read existing comments rather than try
to get people to comment here."

If have read a lot of comments here and found nothing relevant (imho) for this 
specific problem, excuse me for asking for comments jeez..thanks al lot Ben :(

Comment 6

13 years ago
> I have a flash menu (with animations) in a layer on top of several 
> embedded iframes (with plain html AND flash).

I was working on the basis that one of your embedded iframes with flash
was stealing your compositing pipeline and events.

> If have read a lot of comments here and found nothing relevant (imho) 
> for this specific problem, excuse me for asking for comments jeez..thanks al 
> lot Ben :(

If you are sure that you seeing something new, could I suggest that you 
provide a reduced testcase and very simple instructions for reproduction,
including observed and expected behaviour. Make sure that there is one
bug per report.

Good luck!
The testcase in the URL bar works for me -- I can click the submenu things... Is
this still an issue in a current trunk build?
To start, you can only file one issue per bug.

"Offcouse this true concerning the html content underneath but the submenu 
buttons are on the top layer of the flash (swf). So I dont understand why 
Firefox is deleting them when transparancy is off."

No, if wmode isn't set, Flash will default to wmode="window" and render directly to the screen and z-index doesn't matter, by design. It has to be set to transparent or opaque. 

http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=tn_14201

By the way, I've noticed that when you try to put a Flash layer or HTML over windows media player, it doesn't render Flash at all or execute javascript if it's totally blocked by Windows Media Player. This might be an unfortunate result of rendering optimizations that also affects when wmode isn't set to transparent or opaque. In a perfect world, at least, stuff would still be rendered in memory and javascript would be executed whether or not it wouldn't display. (I've also noticed the same thing with opacity set to 0, by the way)

The clickability issue is in bug 259716 which is probably already a dupe (haven't found one yet). No browsers but IE allow clickability of content underneath a transparent area of Flash at this time, unfortunately.

The testcase dissappeared, by the way.

*** This bug has been marked as a duplicate of 259716 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.