Support file version tracking and reg leaves in related APIs.

VERIFIED FIXED in mozilla0.8.1

Status

Core Graveyard
Installer: XPInstall Engine
P2
major
VERIFIED FIXED
18 years ago
2 years ago

People

(Reporter: David Epstein, Assigned: dveditz)

Tracking

Trunk
mozilla0.8.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [xpiprd])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
builds 2000-02-22. all platforms. tried with old and new reg files.
1. Go to http://jimbob/trigger2.html
2. Select a test case. i.e. a_addtestfile, a_adddelfile, a_adddirectory_4, 
a_addsubcomp_full_iver_ver, a_execute, etc.
3. Trigger. OK.
4. Using BiggerRegToy, open reg file in 4.7 (using "Open Registry File" 
pathway).
5. Traverse reg tree with child nodes.
Result: The package gets registered, but not the leaves. So a file or folder, 
for example, will not have a registry entry.
This affects things like file or directory installation which depend upon the 
force parameter (i.e. it will install when force = false and version string is 
smaller, since the previous version is not registered).
(Reporter)

Comment 1

18 years ago
also affects GetVersion, CompareVersion, etc.
Severity: critical → major
QA Contact: jimmylee → depstein
Summary: Installed items (leaves) are not getting registered → Changes to registry affecting addFile & addDir (force mode) & version object tests.
(Assignee)

Comment 2

18 years ago
This was necessary trimming due to Mac performance. We store only the package 
information, not the individual file information.

Dougt has a proposal that we have a way to store specific files, Samir 
suggested we store directory information for addDirectory() calls (but not the 
subfiles added). Discussion will take place in the newsgroup and future bugs 
opened once we know which direction we're going. But this will not change for 
beta, the performance hit the old way was just too great.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 3

18 years ago
per David's comment in the email (below), I think we should leave this bug open 
as a tracking bug for getting those API with regName parameters working again.

Changing summary from
" Changes to registry affecting addFile & addDir (force mode) & version object 
tests." 
to
" Need to support file version tracking "

-----------------------------------------------------------------

> This bug wasn't written because files & directories are no longer registered, 
> but because of the APIs that are broken because of the reg changes. My 
> thinking was that this would be a tracking bug for all the APIs which have a 
> regName parameter (forms of addFile, addDir, compareversion, patch, ...) 
> rather than submit a bug for each one.
> 
> If it's more convenient to write a bug for each one, we can do that. I just 
> thought it would be easier this way. And realizing that this won't be touched 
> for this beta.
>
> - david

Summary: Changes to registry affecting addFile & addDir (force mode) & version object tests. → Need to support file version tracking

Comment 4

18 years ago
reopen bug, and set target milestone to M15
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Target Milestone: M15

Comment 5

18 years ago
reassign to dveditz.
bug meeting 3/20
Assignee: cathleen → dveditz
Status: REOPENED → NEW
(Assignee)

Updated

18 years ago
Target Milestone: M15 → M16
(Reporter)

Comment 6

18 years ago
getComponentFolder also affected by this. Go to http://jimbob/trigger3.html. Try 
a_getcomponentfolder and a_getcomponentfolder_2 from acceptance case menu. Both 
return "null" for directory pathway:

-------------------------------------------------------------------------------
http://jimbob/jars/a_getcomponentfolder.xpi  --  05/01/2000 16:25:50
-------------------------------------------------------------------------------

     Acceptance: a_getcomponentfolder
     --------------------------------

     [1/1]	Installing: C:\Program Files\Netscape\Netscape 
6\a_getcomponentfolder.txt

     Install completed successfully
     ** GetComponentFolder should return path to Program directory: null
     Finished Installation  05/01/2000 16:25:50

-------------------------------------------------------------------------------
http://jimbob/jars/a_getcomponentfolder_2.xpi  --  05/01/2000 16:25:55
-------------------------------------------------------------------------------

     Acceptance: a_getcomponentfolder_2
     ----------------------------------

     [1/1]	Installing: C:\Program Files\Netscape\Netscape 
6\a_getcomponentfolder_2.txt

     Install completed successfully
     ** GetComponentFolder should return path to Program with 
a_getcompfolder_2_subdir: null
     Finished Installation  05/01/2000 16:25:55

Comment 7

18 years ago
must fix in PR2
Keywords: nsbeta2

Comment 8

18 years ago
*** Bug 28897 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
Putting on [nsbeta2+] radar for beta2 fix.
Whiteboard: [nsbeta2+]
(Reporter)

Comment 10

18 years ago
Another API this affects is deleteRegisteredFile(). Script a_delregfile.xpi 
(after running a_adddelregfile.xpi) cancels and returns unidentified value = 3.
(Assignee)

Comment 11

18 years ago
Could you please write up the delete registered file as a separate bug? Even 
once this one is fixed it sounds like calling deleteregisteredfile on a bogus 
regname will give the bogus error 3 -- this needs to be one of the 
approved/documented error codes instead.

Comment 12

18 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta2+] → [nsbeta2+] ETA: 7/15

Comment 13

18 years ago
So, what's the deal with this?  ETA was 7/15...
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta2+] ETA: 7/15 → [nsbeta2+] ETA: 7/20
(Assignee)

Comment 14

18 years ago
Checking our current install scripts none depend on this functionality. I think 
we can live with it post PR2
Keywords: nsbeta3
Whiteboard: [nsbeta2+] ETA: 7/20

Comment 15

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.  Adding "nsbeta3" keyword 
for consideration of a fix for that milestone. 
Whiteboard: [nsbeta2-]
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta2-] → [nsbeta2-][nsbeta3+]
(Assignee)

Comment 16

18 years ago
We can ship without this, it's not causing instability. nsbeta3-
Whiteboard: [nsbeta2-][nsbeta3+] → [nsbeta2-][nsbeta3-]
(Reporter)

Comment 17

18 years ago
Changed summary to reflect leaf-only issue. APIs accepting reg keys (other than 
addFile and addDir) are getVersion, compareVersion, getComponentFolder, and 
deleteRegisteredFile. Spun off other bugs dealing with reg nodes not working in 
APIs (53845 - getversion(), 54086 - delRegFile, 54096 - getCompFile). 
Summary: Need to support file version tracking → Support file version tracking and reg leaves in related APIs.
(Assignee)

Comment 18

17 years ago
Resetting target field for missed milestones
Target Milestone: M16 → ---
(Assignee)

Comment 19

17 years ago
The SmartUpdate site needs this to be able to tell when things have been 
uninstalled.
Keywords: nsbeta2, nsbeta3 → nsbeta1
Whiteboard: [nsbeta2-][nsbeta3-] → [xpiprd]
(Assignee)

Comment 20

17 years ago
Moz 0.8 tasks 
Target Milestone: --- → mozilla0.8

Comment 21

17 years ago
We're past time to cut these low priority bugs from mozilla0.8.  Please update
these bugs today. 
(Assignee)

Updated

17 years ago
Priority: P3 → P2
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.8 → mozilla0.9

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+
(Assignee)

Comment 22

17 years ago
Created attachment 27377 [details] [diff] [review]
patch for this bug, plus some memory cleanup and pruning of dead code
(Assignee)

Updated

17 years ago
Keywords: patch
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9 → mozilla0.8.1

Comment 23

17 years ago
r=ssu

Comment 24

17 years ago
sr=mscott
(Assignee)

Comment 25

17 years ago
fix checked-in 3/13/2001
(Assignee)

Comment 26

17 years ago
fix checked-in 3/13/2001
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 27

17 years ago
changed QA owner to jimmylee.
QA Contact: depstein → jimmylee

Comment 28

17 years ago
Build: 2001-03-15-15-Mtrunk(WIN), 2001-03-15-09-trunk(MAC), 
2001-03-15-08-Mtrunk(LINUX)

Looks fine on all platforms.  Marking Verified.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.