Running SETUP.EXE from SAMBA share yields "Error: File not found install.ini"

RESOLVED DUPLICATE of bug 137380

Status

RESOLVED DUPLICATE of bug 137380
14 years ago
13 years ago

People

(Reporter: stefan.kanthak, Unassigned)

Tracking

1.7 Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
Build Identifier: 

I place the unpacked files of the Mozilla 1.7.5 or 1.7.6 Windows Installer onto
a SAMBA share. Running SETUP.EXE yields "Error: File not found install.ini" and
installations aborts.

Reproducible: Always

Steps to Reproduce:
1. Unpack mozilla-1.7.6.de-AT.win32.installer.exe to SAMBA share
2. Doubleclick SETUP.EXE
3. See error dialog box



Expected Results:  
Install Mozilla

See 137380 too!
The same error was introduced in Firefox 1.0.2 and Thunderbird 1.0.2.
It was NOT in Firefox 1.0 and Thunderbird 1.0
(In reply to comment #0)

> 1. Unpack mozilla-1.7.6.de-AT.win32.installer.exe to SAMBA share
> 2. Doubleclick SETUP.EXE

How do you mean this? Normally i just double-click the installer and then it
runs, asks you where it should install Mozilla, etc.?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> (In reply to comment #0)
> > 1. Unpack mozilla-1.7.6.de-AT.win32.installer.exe to SAMBA share
> > 2. Doubleclick SETUP.EXE
> How do you mean this? Normally i just double-click the installer and then it
> runs, asks you where it should install Mozilla, etc.?

See 137380 for example.
FF, TB and Mozilla installers are all packed with 7zip.
One can unpack them with 7zip or just start the "installation", then
"cd %TMP%" and find the unpacked installer files there.

Since I dislike that all of my users have to unpack the installers (it CAN
take some time on older PCs) and I might have denied execution rights in
%UserProfile% (with ACLs or XPs software restriction policies) to protect my
Windows clients against malware I unpack ALL those selfexpanding installers.

PS: Check 288962 and 288963 too! FF and TB 1.0.2 both have this error too.
    FF 1.0 and TB 1.0 did NOT have it.

Comment 3

14 years ago
I just tried this and it worked.  Windows 2000, Samba 3.0.11, Mozilla 1.7.6
(English).  A long time ago you filed bug 155797--at what point did this start
working for you?

Is this just a problem with the localized build?  Or with an older Samba version?
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 5

13 years ago
I can still reproduce this error, it shows in every version 1.7.* of Mozilla
since I first reported it (and FF and TB too).
Windows 2000 with Service Pack 4, the Rollup Package and all security hotfixes,
Samba 2.2.11-0.1 on Debian 3.0r6, Mozilla 1.7.11 (localized german build).
It shows whether I access the Samba server via UNC path (actually
"\\DEBIAN\PUBLIC\Windows\Mozilla\Mozilla 1.7.11\") or via a mapped drive
(actually "P:\Windows\Mozilla\Mozilla 1.7.11\").

Comment 6

13 years ago
Could you please say if it is the same as in Bug 137380, i.e. changing the permissions helps? Please try a newer Samba like 3.x.
Depends on: 137380
Version: unspecified → 1.7 Branch
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> Could you please say if it is the same as in Bug 137380, i.e. changing the
> permissions helps? Please try a newer Samba like 3.x.
> 

Bingo! chmod u+x (which is mapped to the DOS "archive bit" in my Samba configuration) helps; chmod +x (which means "HSA") naturally works to.

I can't yet upgrade this system to Samba 3.x, but I'll recheck on
another system in the next days, I'm too busy right now.

*** This bug has been marked as a duplicate of 137380 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.