nsGfxFactoryGTK.cpp - identifier "result" is undefined

RESOLVED WORKSFORME

Status

Core Graveyard
GFX: Gtk
--
blocker
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: g. fischer, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; IRIX64 IP27; en-US; rv:1.8b) Gecko/R-A-C
Build Identifier: 

irix 6.5.27, mipspro 7.42.current cvs build.
only for gtk1 build (gtk2 works). last weeks checkout ran fine. but this week:
---------------------------------


gmake[4]: Entering directory `/mnt/3/moz/obj/gfx/src/gtk'
nsGfxFactoryGTK.cpp
Building deps for ../../../../mozilla/gfx/src/gtk/nsGfxFactoryGTK.cpp
CC -o nsGfxFactoryGTK.o -c  -DNATIVE_THEME_SUPPORT -DOSTYPE=\"IRIX6\"
-DOSARCH=\"IRIX\" -DBUILD_ID=0000000000 -DUSE_POSTSCRIPT -I../..
-I../../../../mozilla/gfx/src/gtk/. -I../../../../mozilla/gfx/src/gtk/..
-I../../../../mozilla/gfx/src/gtk/../shared
-I../../../../mozilla/gfx/src/gtk/../x11shared   -I../../../dist/include/xpcom
-I../../../dist/include/string -I../../../dist/include/widget
-I../../../dist/include/view -I../../../dist/include/util
-I../../../dist/include/pref -I../../../dist/include/uconv
-I../../../dist/include/unicharutil -I../../../dist/include/locale
-I../../../dist/include/necko -I../../../dist/include/content
-I../../../dist/include/layout -I../../../dist/include/gfx
-I../../../dist/include -I../../../dist/include/nspr       -KPIC 
-I/usr/local/include -I/usr/nekoware/include  -LANG:exceptions=OFF -woff 3262 -G
4 -n32  -DNDEBUG -DTRIMMED -O3  -I/usr/local/include/glib-2.0
-I/usr/local/lib/glib-2.0/include -I/usr/local/include/pango-1.0
-I/usr/nekoware/include -I/usr/nekoware/include/freetype2
-I/usr/local/include/gtk-2.0 -I/usr/local/include/atk-1.0
-I/usr/local/lib/gtk-2.0/include    -I/usr/local/include -I/usr/nekoware/include
 -DMOZILLA_VERSION=\"1.8b2\" -DMOZILLA_VERSION_MAJOR=1 -DMOZILLA_VERSION_MINOR=8
-DIRIX=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1 -DD_INO=d_ino -DSTDC_HEADERS=1
-DHAVE_ST_BLKSIZE=1 -DHAVE_SIGINFO_T=1 -DHAVE_INT16_T=1 -DHAVE_INT32_T=1
-DHAVE_INT64_T=1 -DHAVE_UINT=1 -DHAVE_UINT_T=1 -DHAVE_UINT16_T=1
-DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1
-DHAVE_NL_TYPES_H=1 -DHAVE_MALLOC_H=1 -DHAVE_X11_XKBLIB_H=1
-DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1 -DHAVE_SYS_CDEFS_H=1 -DHAVE_LIBM=1
-DHAVE_LIBDL=1 -DHAVE_LIBSOCKET=1 -DFUNCPROTO=15 -DHAVE_XSHM=1 -DHAVE_RANDOM=1
-DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1
-DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DHAVE_STAT64=1 -DHAVE_LSTAT64=1
-DHAVE_FLOCKFILE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_STRTOK_R=1
-DHAVE_LANGINFO_CODESET=1 -DHAVE_I18N_LC_MESSAGES=1
-DMOZ_DEFAULT_TOOLKIT=\"gtk2\" -DMOZ_WIDGET_GTK2=1 -DMOZ_ENABLE_XREMOTE=1
-DMOZ_X11=1 -DMOZ_PHOENIX=1 -DMOZ_BUILD_APP=browser -DMOZ_XUL_APP=1
-DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DOJI=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1
-DACCESSIBILITY=1 -DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DMOZ_XTF=1
-DHAVE_GSSAPI_GSSAPI_H=1 -DMOZ_MATHML=1 -DMOZ_LOGGING=1
-DMOZ_USER_DIR=\".mozilla\" -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1
-DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1 -DJS_THREADSAFE=1
-DNS_PRINT_PREVIEW=1 -DNS_PRINTING=1 -DMOZ_ACCESSIBILITY_ATK=1
-DMOZILLA_LOCALE_VERSION=\"1.8b2\" -DMOZILLA_REGION_VERSION=\"1.8b2\"
-DMOZILLA_SKIN_VERSION=\"1.5\"  -D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT
../../../../mozilla/gfx/src/gtk/nsGfxFactoryGTK.cpp
cc-1551 CC: WARNING File = ../../../../mozilla/gfx/src/gtk/nsGfxFactoryGTK.cpp,
Line = 145
  The variable "result" is used before its value is set.

    NS_ADDREF(result);
    ^

cc-1020 CC: ERROR File = ../../../../mozilla/gfx/src/gtk/nsGfxFactoryGTK.cpp,
Line = 155
  The identifier "nsIFontEnumerator" is undefined.

    nsIFontEnumerator *result;
    ^

cc-1020 CC: ERROR File = ../../../../mozilla/gfx/src/gtk/nsGfxFactoryGTK.cpp,
Line = 155
  The identifier "result" is undefined.

    nsIFontEnumerator *result;
                       ^

2 errors detected in the compilation of
"../../../../mozilla/gfx/src/gtk/nsGfxFactoryGTK.cpp".


Reproducible: Always

Comment 1

13 years ago
Reporter, do you still see this error?
(Reporter)

Comment 2

13 years ago
no, but maybe i can't even get so far cause of bug #290886!
(Reporter)

Comment 3

13 years ago
(In reply to comment #1)
> Reporter, do you still see this error?

yes, still happening with deerpark a1!
Assignee: firefox → blizzard
Component: General → GFX: Gtk
Product: Firefox → Core
QA Contact: general → gtk
Version: unspecified → Trunk
how does your .mozconfig (or your configure arguments, if you run it manually) look?

it almost looks like you have no font backend enabled?
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> how does your .mozconfig (or your configure arguments, if you run it manually)
look?
> 
> it almost looks like you have no font backend enabled?

../mozilla/configure --prefix=/usr/local/firefox --disable-composer
--disable-debug --disable-ldap --disable-mailnews --disable-tests
--enable-crypto --enable-optimize='-O3' --disable-installer
--disable-profilesharing --disable-activex --disable-activex-scripting
--disable-gle --disable-dtd-debug --enable-official-branding --disable-freetype2
--disable-gnomevfs --disable-gnomeui --disable-xft --enable-single-profile
--enable-application=browser

ah, I see. that's a gtk2 build btw. (gtk2 is the default, on trunk)

So the default settings are that core X fonts are disabled and xft is enabled,
thus xft is the only font backend. you are disabling it. that leaves no font
backend. that won't give very good results even if that error wasn't there.

I think you want --enable-default-toolkit=gtk.
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> ah, I see. that's a gtk2 build btw. (gtk2 is the default, on trunk)
> 
> So the default settings are that core X fonts are disabled and xft is enabled,
> thus xft is the only font backend. you are disabling it. that leaves no font
> backend. that won't give very good results even if that error wasn't there.
> 
> I think you want --enable-default-toolkit=gtk.

thanks! gtk2 as default must be new. i've never used an extra option for gtk1
for years ;-)
yeah, that changed 2005-03-29 17:17.
(Reporter)

Comment 9

13 years ago
(In reply to comment #8)
> yeah, that changed 2005-03-29 17:17.

indeed!
thanks for the VERY accurate info :-D
(Reporter)

Comment 10

13 years ago
seems to be gone in the meantime.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.