INTERNAL ERROR on Browser End: Could not get the JVM manager; System error?:: Unknown error: 0

RESOLVED FIXED in Thunderbird1.1

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
13 years ago
8 years ago

People

(Reporter: Clint Olsen, Assigned: Scott MacGregor)

Tracking

({fixed1.8})

Thunderbird1.1
x86
FreeBSD
fixed1.8
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050325 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050325 Firefox/1.0.2

I did a search on this and saw this seemed to be an old bug.  I received an
email with two attachments: One a word document, the other a plain/text
attachment.  Trying to preview this message induces the error above in
Thunderbird 1.0.2.  The message layout (from Mutt) is:

  I     1 <no description>                                 [multipa/alternativ,
7bit, 2.8K] 
  I     2 tq><no description>                          [text/plain, quoted,
us-ascii, 0.8K] 
  I     3 mq><no description>                           [text/html, quoted,
us-ascii, 1.7K] 
  A     4 INVITATION - Transfer Pricing 7 April 20       [applica/octet-stre,
base64, 384K] 
  A     5 ATT2622908.txt                               [text/plain, base64,
us-ascii, 0.8K] 

Reproducible: Always

Steps to Reproduce:
1. Click on a particular message (this one having a word and text attachment).




Expected Results:  
Display the message and not crash.
Your Java plugin is incorrectly installed (symlink broken ?)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
I thought Thunderbird wasn't supposed to use plugins?  That's how I read the
previous tickets about this problem.
(Reporter)

Comment 3

13 years ago
After doing a little Bugzilla mining, I applied the --disable-plugins to
the FreeBSD port .mozconfig template and all is well.  If this is required
to get rid of this problem then why isn't it thrown by default in the
Thunderbird build?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
"INTERNAL ERROR on Browser End: Could not get the JVM manager; System error?::
Unknown error: 0" is directly form a a Java plugin which failed to find the JVM.
The plugin calls exit() and that can't thunberird survive.

The reason for this must be that you have a broken JRE symlink in the plugin
directory or that you copied the JRE plugin.

That makes it invalid.
disabling the plugins via configure would be also a solution but that's not the
problem itself.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

13 years ago
Throw me a bone here.  Which plugin directory?  Some system-wide place or in my
home directory?  In a global Mozilla plugin directory or something specific to
Thunderbird?  I only install ports via the FreeBSD ports system, so I don't
quite know how I could have removed anything.  I accept what you say, but unless
you are more specific as to which plugin directory you're talking about, it's
like you're speaking German :)
(Reporter)

Comment 6

13 years ago
I checked my .mozilla/plugins directory, I don't have a broken symlink.  It
points to a valid Java shared library:

$ ll .mozilla/plugins 
total 4
drwxr-xr-x  2 clint  users  - 512 Jan 28 08:23 ./
drwxr-xr-x  4 clint  users  - 512 Jan 27 20:02 ../
lrwxr-xr-x  1 clint  users  -  62 Jan 28 08:23 libjavaplugin_oji.so@ ->
/usr/local/jdk1.4.2/jre/plugin/i386/ns610/libjavaplugin_oji.so

Is there something wrong with using this plugin?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 7

13 years ago
Thunderbird 1.0.2 is certainly compiled with gcc 3. That mean that you need
i386/ns610-gcc32/libjavaplugin_oji.so instead of the one you currently have.

But I think that if thunderbird doesn't run javascript by default, it should
*not* be running java either ? Should we change this bug to a request for
thunderbird not to run java applets in mail ?
(Reporter)

Comment 8

13 years ago
Everything on my system, including the Java plugin, is compiled with gcc 3.4.2.
OS: Linux → FreeBSD
Version: unspecified → 1.0
(Reporter)

Comment 9

13 years ago
Created attachment 186334 [details]
Message which demonstrates the crash

Here is a message from the Lout mailing list that throws Thunderbird into a
tailspin.

Comment 10

12 years ago
same crash and message here with yesterdays thunderbird (linux version 1.0+
(20050720)) on opening any mail on any account or starting to compose a new mail
- removing the link to the java plugin from ~/.mozilla/plugins makes the error
go away - the plugin works fine in the deer park alpha2 browser

peter

Comment 11

12 years ago
Same here [1] on Tbird 1.0.2 for sparc solaris with the link to the Sun java
plugin in  the plugins/directory [2].  I don't see any java in the mail message,
however trying to view it causes the Bird to barf.  Can't attatch the message as
it contains proprietary content.

[1] /apps/mozilla/thunderbird/thunderbird
INTERNAL ERROR on Browser End: Could not get the JVM manager
System error?:: Error 0

[2] ls -l /apps/mozilla/thunderbird/plugins
lrwxrwxrwx   1 root     other         53 Aug  1 08:22 libjavaplugin_oji.so ->
/usr/java/jre/plugin/sparc/ns610/libjavaplugin_oji.so

Comment 12

12 years ago
I have also started to recieve crashes when selecting a message. (Linux)

MOZ_PLUGIN_PATH="/usr/lib/nsbrowser/plugins/"
javaplugin.so ->
/opt/sun-jre-bin-1.4.2.08/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

Comment 13

12 years ago
Get this with Thunderbird 1.5b1 on Solaris/Sparc (built by me). My Tb 1.0.6 uses
the same setup (e.g. MOZ_PLUGIN_PATH) as Tb 1.5b1 without this crash.
Flags: blocking1.8b5?
(Assignee)

Comment 14

12 years ago
we worked around this in 1.0.x. Joe won't like it but we may have to work around
it again in 1.5.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: blocking1.8b5? → blocking1.8b5+
Target Milestone: --- → Thunderbird1.1
(Assignee)

Comment 15

12 years ago
See Bug 289126 for a lot of detail on this issue. 

(Assignee)

Comment 16

12 years ago
Created attachment 197482 [details] [diff] [review]
disable plugins again like we did for 1.0

I was hoping more folks would have updated to the newer version of the java
plugin (which doesn't tell us to abort), but it looks like there are still a
lot of folks out there using this troublesome plugin.

This patch makes 1.5 do what 1.0 did, and that's to disable plugins in
Thunderbird.

I'd rather not check this into the trunk because I'm still hoping that most
users will end up with jvm1.5.0 or higher (which kindly doesn't tell our
process to abort).
Attachment #197482 - Flags: review?(bsmedberg)

Comment 17

12 years ago
(In reply to comment #16)

> I was hoping more folks would have updated to the newer version of the java
> plugin (which doesn't tell us to abort), but it looks like there are still a
> lot of folks out there using this troublesome plugin.

I believe a lot of people still use Java 1.4 since it is default in Solaris 8
and 9. Solaris 10 is the first Sun OE to use Java 1.5 as default.

> I'd rather not check this into the trunk because I'm still hoping that most
> users will end up with jvm1.5.0 or higher (which kindly doesn't tell our
> process to abort).

Fine by me but then it probably should be noted in the Release Notes somewhere
that it needs Java 1.5.

And how come Firefox doesn't have this problem?

Comment 18

12 years ago
probably because firefox has a jvm manager :)

Comment 19

12 years ago
Comment on attachment 197482 [details] [diff] [review]
disable plugins again like we did for 1.0

Ick. This error only happens on linux, right? Couldn't we do something less
severe like preffing plugins off, or preffing plugins off only on linux?
Attachment #197482 - Flags: review?(bsmedberg) → review+

Updated

12 years ago
Attachment #197482 - Flags: approval1.8b5+
(Assignee)

Comment 20

12 years ago
we've worked around this again on the 1.8 branch.

Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago12 years ago
Keywords: fixed1.8
Resolution: --- → FIXED

Comment 21

12 years ago
(In reply to comment #19)

> Ick. This error only happens on linux, right? Couldn't we do something less

On Solaris too.
(Assignee)

Updated

12 years ago
Blocks: 308647

Comment 22

12 years ago
thanks for resolving this bug which resolved also my bug
https://bugzilla.mozilla.org/show_bug.cgi?id=308647 for some podcast rss feed

Comment 23

11 years ago
Regression: reappearing in trunk build version 3 alpha 1 (20061008) on Linux.
Moving libjavaplugin_oji.so out of $HOME/.mozilla/plugins fixes it but deprives firefox off Java.

I don't have powers to reopen...

Michael

Comment 24

8 years ago
Had the exact same issue on beta 3.0. 
INTERNAL ERROR on Browser End: Could not get the plugin manager
System error?:: No such file or directory

Fixed it by running 3.1 alpha1. Sweet!
You need to log in before you can comment on or make changes to this bug.