Closed Bug 289191 Opened 18 years ago Closed 18 years ago

Selecting text with a light color on a light background results in a white background-color for ::selection

Categories

(Core :: DOM: Selection, defect)

x86
All
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla1.8beta2

People

(Reporter: uruviel, Assigned: masayuki)

References

Details

(Keywords: testcase)

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050405 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050405 Firefox/1.0+

When selecting a piece of text with a light color (specified in the CSS)on a
light background. The selection color is white.

Reproducible: Always

Steps to Reproduce:
1.Select a piece of light coloured text on a light background


Actual Results:  
You see a darkblue on white selection

Expected Results:  
You should see a white on darkblue selection
Attached file testcase
I was unable to find the specific value for the triggering of a light
background.
But here are some examples
Status: UNCONFIRMED → NEW
Ever confirmed: true
Caused by recent checkin for bug 56314.
Attached image screenshot
Difference selected between Firefox, IE and Opera
Blocks: 56314
Flags: blocking1.8b2?
Keywords: testcase
OS: Windows XP → All
No longer blocks: 56314
Depends on: 56314
When applying the css attribute font-variant even stranger behaviour is shown.
For color: black the selection now becomes black on dark-blue and for color:
white
the selection now becomes white on white.
That looks bad....  Looks like some codepaths got patched but not others, or
something.
Assignee: selection → masayuki
Severity: minor → major
Comment 5's problem is not related this bug.
We should separate to new bug.

This problem is fixed by bug 56314's new patch.
-> FIXED
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.8beta2
So is bug 290920 the bug on the issue in comment 5?
Flags: blocking1.8b2?
You need to log in before you can comment on or make changes to this bug.