div + absolute positioning + overflow:auto = no scroll wheel

VERIFIED DUPLICATE of bug 97283

Status

()

Core
Layout: View Rendering
VERIFIED DUPLICATE of bug 97283
14 years ago
14 years ago

People

(Reporter: Justin Ryan, Assigned: roc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041217
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041217

We developed this layout using absolute positining to simulate the feel of a
menu bar or toolbar at the top of a page, and still have scrolling content.  The
page referenced explains some details, but I'll summarize here.  when you use
overflow:auto on an absolutely positioned div, the scrollwheel does not function
in mozilla.  overflow:auto is not necessary to cause a div like this to scroll
in mozilla, but is in IE.  I know, it's their fault, but I wish this
compatability fix didn't break Moz.  The site explains a workaround using
javascript to dig into the dom and toggle this property for either browser.  ick.

Reproducible: Always

Steps to Reproduce:
1. Create a page like the one referenced with an absolutely positioned div that
has overflow:auto set on it.
2.Load this page on a machine with a scrollwheel type device in _any_ gecko
based browser from Mozilla/Linux to Camino/OSX
3. Try to scroll using the wheel or similar device
Actual Results:  
no dice, have to scroll using the scrollbar.

Expected Results:  
scroll the main content area, as happens when the 'overflow:auto' attribute is
removed.

This issue has been around for over two years for sure, in all iterations of
mozilla / gecko.
This is fixed on trunk and will ship with the next major version of Firefox.

*** This bug has been marked as a duplicate of 97283 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.