scrolling behaviour is wonky with new touchpad on powerbook

RESOLVED DUPLICATE of bug 282140

Status

SeaMonkey
UI Design
--
major
RESOLVED DUPLICATE of bug 282140
13 years ago
9 years ago

People

(Reporter: Justin Ryan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041217
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041217

The new Apple Powerbook have a feature in the touchpad which allows it to behave
like a scrollwheel when two fingers are used instead of one.  This works
correctly in Camino, but not in Mozilla or Firefox - they both respond to it,
but want to use slight sideways movement or tapping of the pad as back/forward
actions.  it's very neurotic.

Reproducible: Always

Steps to Reproduce:
1. get ahold of a recent powerbook (12" 1.5ghz, 15"/17" 1.67ghz) with scrolling
touchpad feature
2.load up any version of mozilla or firefox that you like
3.try to use the scrolling touchpad feature
4. fire up safari or camino and try the same for an example of proper behaviour
Actual Results:  
the page jumps around all crazily and goes back and forth through history instead

Expected Results:  
scrolled smoothly.

Sometimes this is a cause of loss of form data, and it just generally disallows
natural use of a feature which isn't broken in any other applications I've tested.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 282140 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.