Double-clicking on a twisty in sidebar loads bookmarks.xul into content area, or crashes

VERIFIED FIXED

Status

defect
P1
critical
VERIFIED FIXED
20 years ago
15 years ago

People

(Reporter: mozilla, Assigned: slamm)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

By mistake, I double-clicked a few times on a twisty in the bookmark's sidebar 
panel (I meant to double-click on the bookmark itself, but was a few pixels 
off).  What ended up happening was that bookmarks.xul was loaded into the 
content area of the browser window... a few more extra double-clicks caused us 
to crash.

This is on my Win98 box, not sure what happens on other platforms.

David, any idea on this?
Priority: P3 → P1
My guess is that the double-click event is being bubbled up from the twisty to the event handler on the <tree>. We should probably just condition the event handler to be smarter. I actually make use of the fact that I can get twisty events; e.g., in the file browser. So I consider this a "feature", not a bug.
check event.target.
Assignee: hyatt → slamm
Severity: major → critical
Keywords: crash
Remove 'crash' keyword. This doesn't cause a crash last time I checked...
Keywords: crash
In the 2000030708 build (Win32), I was able to induce a crash 1 out of 3 times 
by clicking repeatedly on a twisty in the bookmarks panel in the sidebar.

I have no idea what was done differently during that one test to bring about the 
crash. Sorry...
Fixed.

Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
*** Bug 32277 has been marked as a duplicate of this bug. ***
verified 4/10
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.