download manager text is cut off if too long

RESOLVED FIXED in Camino1.5

Status

Camino Graveyard
Downloading
--
trivial
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Ryan Foley, Assigned: Nick Kreeger)

Tracking

({fixed1.8})

unspecified
Camino1.5
PowerPC
Mac OS X
fixed1.8

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050325 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050325 Camino/0.8+

When downloading, the text in the manager (i.e. "XXX of YYY (at ZZZ)") is cut
off if it is long enough and the download manager window is small enough.

Reproducible: Always

Steps to Reproduce:
1. Download a file (the larger the better)
2. Shrink the download manager as small as possible in the horizontal direction

Actual Results:  
If the text is long enough, the last few words (like KB/sec) are cut off


Expected Results:  
The text should wrap or there should be a scrollbar at the bottom
no scrollbar. we should probably use ellipsis to indicate there's more text. if
the user really cares, they can make the window wider.
Target Milestone: --- → Camino1.1
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

13 years ago
Taking, shouldn't be hard to fix..
(Assignee)

Comment 3

13 years ago
Using source pulled and build yesterday (Aug. 2) I cant reproduce the problem.
When the window is resized, it has a minimum size for the window, thus allowing
enough room for the downloading and not cutting off any of the progress text.

Anyone else have the same?

Comment 4

13 years ago
I guess that the reporter had a case of downloading something xxx (couple
hundred mb file) and in that case I can see how we crop the text.

In any case we should fix that, but also take care of the situation where the
file name is very long.
You'll see truncated "status info" if you try to download an Xcode update and
have the DL Mgr window at its smallest.  I imagine people who download larger
files like ISOs and such may even see it at wider widths (I've seen it at least
once at a wider-than-smallest width, but I can't recall what I might have been
downloading).

Also, as Jasper noted, long file names, e.g. the latest Xcode preview, get
truncated (this happens for me even at my normal DL Mgr width, so even more
truncation would happen at the smallest width).
-> Kreeger
Assignee: pinkerton → nick.kreeger
(Assignee)

Comment 7

13 years ago
Created attachment 194239 [details]
Updated ProgressView.nib

Updated ProgressView.nib. Adds "..." to a filename, downloadsize/transfer rate,
and time remaining if the window cuts off the text.
(Assignee)

Comment 8

13 years ago
Created attachment 194249 [details]
Updated to have truncate middle on file name, and truncate tail on the download info line
(Assignee)

Updated

13 years ago
Attachment #194239 - Attachment is obsolete: true

Updated

13 years ago
Attachment #194249 - Flags: review+

Comment 9

13 years ago
Checking in
trunk/mozilla/camino//resources/localized/English.lproj/ProgressView.nib/keyedobjects.nib;
/cvsroot/mozilla/camino/resources/localized/English.lproj/ProgressView.nib/keyedobjects.nib,v
 <--  keyedobjects.nib
new revision: 1.3; previous revision: 1.2
done
Checking in
1.8/mozilla/camino/resources/localized/English.lproj/ProgressView.nib/keyedobjects.nib;
/cvsroot/mozilla/camino/resources/localized/English.lproj/ProgressView.nib/keyedobjects.nib,v
 <--  keyedobjects.nib
new revision: 1.2.2.1; previous revision: 1.2
done
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.