/quit in Chatzilla kills Firefox

RESOLVED DUPLICATE of bug 289379

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 289379
13 years ago
13 years ago

People

(Reporter: Peter6, Assigned: Blake Ross)

Tracking

({crash, regression})

Trunk
x86
Windows 2000
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050406
Firefox/1.0+ 10:18 PDT

repro
1.Open FF
2.Open Chatzilla extension (build 0.9.67-20050325, see
http://www.extensionsmirror.nl/index.php?showtopic=153&hl=chatzilla ) 
3.type /quit
4.Windows message: Firefox has generated errors and is closed by Windows
5.FF crashes/is closed
6.No activation of talkback so there is no way to tell who's to blame (FF or CZ)

regressed beween 20050405 15:06PDT and 20050406 10:18PDT

(I have no idea what Product/Component this belongs to)
(Reporter)

Updated

13 years ago
Severity: normal → major
Keywords: regression
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050406
Firefox/1.0+ (firefox.exe created 06 April 2005, 11:50:12)
I also see this.
New profile, Installed Chatzilla 0.9.67, Tried to connect to an irc server,
choose /exit and firefox crashed out too.
(Reporter)

Comment 2

13 years ago
Simply closing the window/tab that contains CZ does not lead to Firefox crash
(Reporter)

Comment 3

13 years ago
When I simply open another page in CZ's tab I see the following error in
JSConsole: Error: 
CEvent is not defined
Source File: chrome://chatzilla/content/lib/js/irc.js
Line: 592

>   var ev = new CEvent ("server", "disconnect", this, "onDisconnect");
    ev.server = this;
    ev.disconnectStatus = status;
    this.parent.eventPump.addEvent (ev);

Comment 4

13 years ago
Marking dupe of bug 289379 (it does contain fix).

*** This bug has been marked as a duplicate of 289379 ***
Severity: major → critical
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: crash
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.