DIVs shift and grey areas appear when scrolling page on Firefox

RESOLVED FIXED in mozilla1.8beta3

Status

Core Graveyard
Widget: Mac
P2
normal
RESOLVED FIXED
13 years ago
8 years ago

People

(Reporter: jhp (no longer active), Assigned: Simon Fraser)

Tracking

({testcase})

Trunk
mozilla1.8beta3
PowerPC
Mac OS X
testcase
Bug Flags:
blocking1.8b2 -
blocking1.8b3 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact], URL)

Attachments

(2 attachments)

5.91 KB, text/html
Details
2.40 KB, patch
Mark Mentovai
: review+
jhp (no longer active)
: review+
Simon Fraser
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
When scrolling the page listed in URL field, parts of the page shift
unnaturally, and grey areas appear.  Happens on Firefox/Mac, but not on other
platforms, and not on Camino, which means that it might point to a bug in the
carbon widget code.
(Reporter)

Comment 1

13 years ago
Seems to be related to the floating DIV on the left hand side.  If I remove that
from the HTML code, then I don't see the ugliness any more.
(Reporter)

Comment 2

13 years ago
Created attachment 179883 [details]
reduced testcase

Greatly reduced testcase.  To reproduce, it requires both that there be a
floating (fixed) DIV, and that the content DIV have "overflow:auto" set.

Comment 3

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050407
Firefox/1.0+

I can see this.

Updated

13 years ago
Keywords: testcase

Updated

13 years ago
Flags: blocking1.8b2?
Flags: blocking-aviary1.1?

Comment 4

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050408
Firefox/1.0+

There is also a update/dirty/redraw problem in which sometimes when moving 
to a new URL, parts of the previous one 'show through'. I don't have a
recipe for reproduction.

Comment 5

13 years ago
(In reply to comment #4)
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050408
> Firefox/1.0+
> 
> ... I don't have a recipe for reproduction.

O.K. I realise that that is a little unsatisfactory. Here a receipe that works 
most of the time:

Go to a page like http://e2fsprogs.sourceforge.net/ which has links to a
'Sourceforge ummary page'.

Open that link and others in new tabs, Cmd-click for example. Go another
tab, and then to the summary page.

If my recipe worked, the the advert at the top (a javascript write( )) will
not have been painted, and will show what was on the previous tab. Refreshing,
or returning again will cause a repaint.

I suspect that this is a minor regression, or a manifestation of the problem
reported in comment 0 rather than anything major, but it may be a little
early to be certain.

Updated

12 years ago
Flags: blocking1.8b3?
Flags: blocking1.8b2?
Flags: blocking1.8b2-
(Assignee)

Updated

12 years ago
Priority: -- → P2
Target Milestone: --- → mozilla1.8beta3

Comment 6

12 years ago
Can you test with a nightly trunk build? We just switch mac to use a new
eventloop model that will probably significantly hide the symptoms here.
(Assignee)

Comment 7

12 years ago
I doubt the new event handling will fix this. It's a bug in the mac widget code.

Comment 8

12 years ago
Do the same symptoms appear in camino (cocoa widgets)?
(Assignee)

Comment 9

12 years ago
(In reply to comment #8)
> Do the same symptoms appear in camino (cocoa widgets)?

No.

Updated

12 years ago
Flags: blocking1.8b4?
Flags: blocking1.8b3?
Flags: blocking1.8b3-

Comment 10

12 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050702
Firefox/1.0+

Still in.

Updated

12 years ago
Whiteboard: [no l10n impact]

Updated

12 years ago
Flags: blocking-aviary1.1?

Comment 11

12 years ago
This bug is very similar to bug 259563, which has a testcase with both
'overflow:scroll' and 'overflow:auto'.
(Assignee)

Comment 12

12 years ago
*** Bug 259563 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

12 years ago
Created attachment 189847 [details] [diff] [review]
Patch

The bug was that the code paths through nsWindow::Scroll that hit the
Invalidate() calls caused the window state (probably the update region) to be
left in a bad way for later drawing. The easiest fix for this is to make the
invalidates asynchronous.
Attachment #189847 - Flags: superreview?(jhpedemonte)
Attachment #189847 - Flags: review?(mark)

Updated

12 years ago
Attachment #189847 - Flags: review?(mark) → review+
(Reporter)

Updated

12 years ago
Attachment #189847 - Flags: superreview?(jhpedemonte) → review+
(Assignee)

Updated

12 years ago
Attachment #189847 - Flags: superreview?
(Assignee)

Comment 14

12 years ago
Comment on attachment 189847 [details] [diff] [review]
Patch

I approve!
Attachment #189847 - Flags: superreview?
Attachment #189847 - Flags: superreview+
Attachment #189847 - Flags: approval1.8b4?
Comment on attachment 189847 [details] [diff] [review]
Patch

So do I! a=shaver
Attachment #189847 - Flags: approval1.8b4? → approval1.8b4+
(Assignee)

Updated

12 years ago
Assignee: joshmoz → sfraser_bugs
(Assignee)

Comment 16

12 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Flags: blocking1.8b4?
(Assignee)

Comment 17

12 years ago
*** Bug 228838 has been marked as a duplicate of this bug. ***

Comment 18

12 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) 
> > Gecko/20050408 Firefox/1.0+
> > 
> Go to a page like http://e2fsprogs.sourceforge.net/ which has links to a
> 'Sourceforge Summary page'.
> 
> Open that link and others in new tabs, Cmd-click for example. Go another
> tab, and then to the summary page.
> 
> ...

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050805
Firefox/1.0+

I am not seeing this problem (nor the defect reported in comment 0 ). I suspect
that this bug has many duplicates.

I will open a new report if I see it again, but it likely fixed.
(Assignee)

Comment 19

12 years ago
*** Bug 292935 has been marked as a duplicate of this bug. ***

Updated

8 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.