semi-colon not accepted as address separator leading to problems receiving and replying

RESOLVED DUPLICATE of bug 210521

Status

RESOLVED DUPLICATE of bug 210521
14 years ago
14 years ago

People

(Reporter: mh519, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1
Build Identifier: version 1.0.2-1.3.2 (20050324)

I received an email with the following 'To:' field in the message source.
To:
nursiesian@hotmail.com;02000147@brookes.ac.uk;singhmeistergeneral@hotmail.com;mikeyeast@hotmail.com;sarrah55@hotmail.com;ed_macdonald@msn.com;nutta29@hotmail.com;adam@kinkt.co.uk...
(were about 30 addresses in all)

Thunderbird does not recognise semi-colons (;) as a seperator as it does a comma
(,), so this led to two problems.

1) The email addresses were not seperated, so Thunderbird attempted to display
them all as one very long address. This did not wrap, but instead stretched some
of the message list, expanding the subject field in the message list off the
edge of the screen, meaning I lost the date received column and some other
fields (will post screenshot) . Clicking on another email put Thunderbird back
to normal.

2) When I tried to reply-to-all, the same 'to:' list appeared in the compose
window. The semi-colons were not accepted as separators so TB treated it as one
long email address which was not accepted. To reply I had to manually change all
semi-colons to commas.

Thunderbird should support semi-colons as separators for compatibility with
clients that do, to avoid the above problems.

Reproducible: Always

Steps to Reproduce:
1. Send an email from Outlook or another mail client allowing semi-colons as
separators to be received in Thunderbird
2. Load the mail
3. Try to reply
Actual Results:  
During 2 - Fields in message pane lost
During 3 - Will not send, as TB thinks is one long malformatted address

Expected Results:  
2 - Mail displays as if comma was used as seperator, showing only first 3 addresses
3 - Can reply as normal.
(Reporter)

Comment 1

14 years ago
Created attachment 179953 [details]
screenshot showing problems when long email address is display, not wrapping.

shows fields missing in message list pane because of the long address list not
being separated.

Comment 2

14 years ago
If the actual "To" header in the message contains addresses separated by
semicolons, that would seem to be a malformed header. According to RFC 2822
<http://www.faqs.org/rfcs/rfc2822.html> section 3.4, semicolons are used to
terminate address groups, but not to separate individual addresses.

Comment 3

14 years ago
See also bug 242693, bug 258653.

*** This bug has been marked as a duplicate of 210521 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.