Group-by Sort headers are targets for "next message"

RESOLVED FIXED in Thunderbird2.0

Status

--
minor
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: hacksoncode, Assigned: Bienvenu)

Tracking

({fixed1.8.1})

Trunk
Thunderbird2.0
fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
When a new message arrives, it gets sorted into one of the group-by sections
(e.g. "Today". If you are in, for example, "Yesterday" and you hit "N",
Thunderbird uselessly advances to the group label, not showing any new message.
A second "N" causes an advance to the desired message.

Thunderbird build: 20050315

Expected result: TB should advance to the next actual new message and display it
without stopping at the label.

Updated

13 years ago
Severity: normal → minor
OS: Windows XP → All
Hardware: PC → All
Summary: Group-by Sort labels are targets for "next message" → Group-by Sort headers are targets for "next message"
Version: unspecified → Trunk

Comment 1

13 years ago
Ray Trent, I'm unable to reproduce this problem with TB 1.5.0.2 or later 
builds.  Are you still seeing the symptom?  If not, please mark this bug:
  Resolved | WorksForMe
(Assignee)

Comment 2

13 years ago
this happens to me with a 2.0a build when I'm grouped by date - I think it has always been this way.
(Assignee)

Comment 3

13 years ago
Created attachment 222935 [details] [diff] [review]
proposed fix

make sure we think the dummy header has the "read" flag set.
Assignee: mscott → bienvenu
Status: NEW → ASSIGNED
Attachment #222935 - Flags: superreview?(mscott)

Updated

13 years ago
Attachment #222935 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 4

13 years ago
Here's one way of reproducing this:

1. Group by date, so that today's messages are at the top.
2. Mark all the messages from yesterday as unread
3. Select the last message in today.
4. Do next unread

That will take you to the dummy header for yesterday. The key to reproducing this is that the dummy header was getting its read state from the *first* message in the yesterday group, which is most likely to be the oldest message from yesterday, *not* the first message in the yesterday group. Hope that make sense.
(Assignee)

Comment 5

13 years ago
fixed on trunk; I'll get it into 2.0 when the tree is open...
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird2.0
(Assignee)

Comment 6

13 years ago
Comment on attachment 222935 [details] [diff] [review]
proposed fix

putting on 2.0 radar
Attachment #222935 - Flags: approval-branch-1.8.1+
(Assignee)

Updated

13 years ago
Keywords: fixed1.8.1
You need to log in before you can comment on or make changes to this bug.