max-width: length directive doesn't wrap correctly

RESOLVED DUPLICATE of bug 95067

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 95067
13 years ago
13 years ago

People

(Reporter: PHANTOm, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

try this page on IE and FF and see how it doesn't wrap correctly.

Reproducible: Always

Steps to Reproduce:
1.go to example page in ff
2.go to example page in ie

Actual Results:  
you see what's wrong

Expected Results:  
should render like in IE
(Reporter)

Updated

13 years ago
Component: GFX → HTML: Parser
(Reporter)

Updated

13 years ago
Component: HTML: Parser → Layout: View Rendering
I don't see any use of 'max-width' in the screen stylesheet or the page.

Bugs should be filed with clearer steps to reproduce.  I don't have access to
IE/Windows.  It's likely that this is invalid anyway.
Assignee: general → nobody
Component: Layout: View Rendering → Layout
QA Contact: ian → layout

Comment 2

13 years ago
The minimum width for the table is limited by the cell with the following text:

$t->page('PasteBin','PasteBin','pastebin/','PasteBin',array(array('Scripts','scripts/',''),array('WebChat','http://chat.nix.co.il/',''),array('Support','support/','')));

The only line breaking opportunity is the '-' at the beginning of the text
as far as can tell, which means Mozilla's layout is correct, or nearly at
least. Line breaking at '-' is bug 95067.

Comment 3

13 years ago
It's line 3 BTW.

*** This bug has been marked as a duplicate of 95067 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.