Uncaught exception when trying to mark a checkbox in an XML application. nsIXMLHttpRequest.open NS_ERROR_FAILURE

RESOLVED WORKSFORME

Status

()

Core
XML
--
major
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Tristor, Unassigned)

Tracking

({helpwanted, qawanted})

Trunk
x86
Windows XP
helpwanted, qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: regression?, URL)

(Reporter)

Description

14 years ago
This problem doesn't appear in either branch builds or last nights nightly
trunk, so I am thinking it might be a regression.  It appears somewhat similar
to bug 289456, but I was informed in IRC that it was something completely
different and to go ahead and file.

On tadalist, when I mark an item's checkbox, it is supposed to change colors,
fontsize, and drop to the bottom of the todolist.  In the 20050407 build, it
does not exhibit this behavior.  When marking the checkbox, it shows the mark,
but the item doesn't move on the page, and no other styling changes are made. 
If you go back to the main 'menu' page for your tadalist, you will see that it
also does not record the change and that the item is still present as being
unfinished on your list.

When marking the checkbox, the following error is recieved on the Javscript Console:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIXMLHttpRequest.open]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
http://tristor.tadalist.com/javascripts/lists.js :: xml_request :: line 138" 
data: no]

Unrelated, but possibly important, the stylesheet on that page doesn't validate,
and gets the following error on the JS Console:

Error: Expected color but found '#red'.  Expected color but found '#red'. 
Expected end of value for property but found '#red'.  Error in parsing value for
property 'border'.  Declaration dropped.
Source File: http://tristor.tadalist.com/stylesheets/screen.css
Line: 960


Steps to Reproduce:

1. Goto your tadalist
2. Login
3. Choose a list you have previously created
4. Check the box next to one of the items

Actual Results:

The item is not dropped to the bottom of the list and subdued, and when going
back to the 'menu' of lists, you notice that it has not recorded you checking
that item off.  Error appears on the console about an uncaught exception.

Expected Results:

Item drops to the bottom of the page, is restyled, and result is recorded.  No
error on the console appears.



I will see if I can't whip up some sort of reduced testcase for this, if I can
figure out exactly what it is that is causing the issue.  Adding qawanted
keyword for help with a testcase since my XML skills suck, although I will see
what I can do.
(Reporter)

Updated

14 years ago
Whiteboard: regression?
(Reporter)

Comment 1

14 years ago
It appears that I forgot to include build/UA information, since I didn't use the
guided bug report system this time.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050407
Firefox/1.0+

Also, adding keywords helpwanted and clean-report on the suggestion of Robin
Monks in IRC.
Keywords: clean-report, helpwanted

Comment 2

14 years ago
Confirmed, checking the box does not mark it done as it did previously.

This probably happens with Basecamp too.  I can't confirm this, get
Chris.Messina to check it out though on the sfx.grouphub.com extranet.

Comment 3

14 years ago
Sorry for the additional bugspam, here's the UA that I got onto tristor about,
and then happened to be guilty of myself.

Oh the shame.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050407
Firefox/1.0+
(Reporter)

Comment 4

14 years ago
Adding some search keywords to the summary as suggested by someone in IRC.
Confirming, and adding Tom to the CC list.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Uncaught exception when trying to mark a checkbox in an XML application. → Uncaught exception when trying to mark a checkbox in an XML application. nsIXMLHttpRequest.open NS_ERROR_FAILURE
(Reporter)

Comment 5

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050408
Firefox/1.0+

Reproduces on 20050408 as well.
(Reporter)

Comment 6

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050409
Firefox/1.0+

WFM on 0409 build.  Whatever happened on the 6th that broke it must have been
fixed.  Anybody else see this as working?
(Reporter)

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.