Status

()

defect
--
major
RESOLVED DUPLICATE of bug 237582
15 years ago
14 years ago

People

(Reporter: cowwoc2020, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

On slow websites, if you open up 5-10 tabs and try clicking on links, or even
hitting back the website will take sometimes 10 seconds to reply. Deviantart.com
is a good example of time.

This is not the problem. The problem is that during the transition period (when
you click on a link or hit BACK -- before the rendering process completes)
FireFox will use up 100% cpu. No other browser seems to have this problem.

It almost looks like FireFox is doing network polling under the hood instead of
select() on sockets. Something is majorily screwed. Anyway, the expected
behavior is that cpu usage should be extremely low while waiting on slow
websites to respond. If the website responds at 1k/s, FireFox should not use up
100% cpu.

Reproducible: Always

*** This bug has been marked as a duplicate of 237582 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.