getting mess of old messages instead of new message on message receipt

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Ivan Ičin, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050326 Firefox/1.0+ (MOOX M2)
Build Identifier: Thunderbird version 1.0+ (20050406)

Subject, date, sneder are shown in messages list, but it is not shown in headers

Reproducible: Always

Steps to Reproduce:
see the testcase
(Reporter)

Comment 1

13 years ago
Created attachment 180087 [details]
testcase for the bug
(Reporter)

Updated

13 years ago
Version: unspecified → Trunk

Comment 2

13 years ago
does this happen on all messages, or just the testcase?
(Reporter)

Comment 3

13 years ago
Just in testcase. It is some spam I have received today.

Comment 4

13 years ago
I'm not sure which part of the attachment, which contains two full messages and 
a fragment from another, is supposed to be relevant.  The two full messages, 
integrated into my mail, both show the header info in the Thread Pane and in the 
Envelope Panel.  TB 1.0+0407, Win2K.
(Reporter)

Comment 5

13 years ago
It is just one message, I saved it with File/Save as. It might contain several
messges, probably spammers trick.

I've tried to reintegrate testcase file I have saved in my Inbox (using
extension), but imported message doesn't look like testcase message, so it is
possible that there is some problem in importing of this message...

If you open testcase file with Outlook Express, the message looks the same like
I see in Thunderbird, and the headers are empty.

I still have message in my inbox, if I can help somehow.

Comment 6

13 years ago
it looks to me like the wrong offset into the mail store is stored in the .msf
file, so that we think the beginning of the message is really partways into the
body of the previous message. deleting the .msf file will probably fix this, but
the question still is, why is the wrong offset stored in the db?
(Reporter)

Comment 7

13 years ago
If it helps, here are the details of what I see in message list:

Sender: Felipe Pope
Subject: Software 3000 fetal
Date: 8.4.2005 19:49
(Reporter)

Comment 8

13 years ago
What actually happened was that on message receipt I got a new message that
consists of several old messages instead of new message, though data in message
list was OK. It happened on every message I have received in inbox, so if
message was filtered to some other folder there were no problems.

It seems that everything is fine after compacting inbox folder, so I'll wait for
some time and if everything works fine, I'll close the bug.
Summary: subject and sender shown in list, but not in headers → getting mess of old messages instead of new message on message receipt
(Reporter)

Comment 9

13 years ago
It seems that this bug is happening again in my inbox. All messages that end in
that folder have content of my previous messages.
(Reporter)

Comment 10

13 years ago
The problem was that something went wrong with inbox.msf

After deleting it I think that everything is OK, as old messages reappeared.

I guess that this file has some data about senders (though it is mostly
irrelevant, as I keep my contacts in other folder), so I wouldn't like to attach
it here, but if someone is interested to see what went wrong, I can send it on
e-mail.
(Reporter)

Comment 11

13 years ago
I think that it was fixed when one other bug was fixed (so they were likely
duplicates), but it is irrelevant now.

Anyway, I can't reproduce bug now, and as I was the only one who reproduced it,
works for me is fine resolution, I think.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.