Combo box only display part of all possible choices

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Bernard Alleysson, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050407
Firefox/1.0+

1. go to URL
2. expand combobox

notice that some options display as blank items
(Reporter)

Comment 1

13 years ago
Created attachment 180089 [details]
Screenshot
(Reporter)

Updated

13 years ago
Summary: Combo box onnly display part of all possible choices → Combo box only display part of all possible choices

Comment 2

13 years ago
I see something similar with IE--a whole bunch of empty options at the end after
"Voiron"
(Reporter)

Comment 3

13 years ago
"Voiron" is the last item. No problem with IE.
It looks like a reflow bug, probably a dupe but I couldn't find it.

Comment 4

13 years ago
Forgot to add, IE and Moz 1.7.6/Win2k look the same in this regard.  So possibly
a regression.

Comment 5

13 years ago
WFM, I see all choices with Mozilla 1.8b1, Mozilla 1.8b2 Gecko/20050322 and IE6. 

(In reply to comment #2)
> I see something similar with IE--a whole bunch of empty options at the end after
> "Voiron"

If I look at the page source I see a lot of empty <OPTION VALUE=></OPTION>'s
(507 times) after "Voiron", so I guess that's to be expected. 
(Reporter)

Comment 6

13 years ago
maybe related to bug 283117 ?
Note that it's not 100% reproductible, it seems to occur more reliably when the
list is expanded while the page is loading. Reloading the page seems to fix it.
Assignee: firefox → nobody
Component: General → Layout: Form Controls
Product: Firefox → Core
QA Contact: general → layout.form-controls

Comment 7

13 years ago
This worksforme with linux trunk 20050409, but the symptoms are similar to bug
289730.  Can someone d/l nightlies and narrow down the regression?  If the bug
exists in 20050406, then it's not related to bug 289730.
Depends on: 289730
(Reporter)

Comment 8

13 years ago
WFM (fixed by bug 289730) Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.8b2) Gecko/20050413 Firefox/1.0+
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
No longer depends on: 289730
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.