Text selection is wrong after newline and CJK bracket

RESOLVED WORKSFORME

Status

()

Core
Selection
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Ng Ming Hong, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.21 KB, application/xhtml+xml
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050408 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050408 Firefox/1.0.3

Tryout the test case. Basically the problem is that when a CJK bracket character
is found right after a newline character, the selection of any character after
that (including the bracket itself) is offset by one character.

Interestingly, this bug doesn't occur for other CJK punctuation marks like comma
and full stop.

Reproducible: Always

Steps to Reproduce:
1. Follow the procedures in the test case
Actual Results:  
Selection is offset by one.

Expected Results:  
Select correctly.
(Reporter)

Comment 1

13 years ago
Created attachment 180153 [details]
Test case

P.S. This bug may be related to bug 208199, through I'm not sure.
confirmed linux pango firefox trunk 20050407. Conversely, double click word
select seems to find the right (including the adjacent bracket though, which
doesn't happen on ascii brackets) characters, but is visually off by one.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
(Reporter)

Comment 3

12 years ago
WFM in 2.0 Beta 1, shall we mark this bug as FIXED?
I see the problem in Firefox 1.0 (Gecko 1.7), but not in Firefox 1.5 (Gecko 1.8) and onwards. Resolving WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.