feature request: possibility to disable javascript right mouse click events

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
14 years ago
12 years ago

People

(Reporter: master-andre, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050327 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050327 Firefox/1.0.2

I'm looking for an option to disable the right mouse click events for javascript
(like "hide the status bar" or "change images" and so on) 

->preferences->web features->Enable Javascript->Advanced

that screws up my mouse gestures on some pages with javascript prohibiting right
mouse events for copyright protection

Reproducible: Always

Steps to Reproduce:
visit a page with mentioned javascript right mouse click event
Actual Results:  
javascript blocks my mouse gestures (right mouse button)

Expected Results:  
prohibit javascript from get these mouse events
type about:config in the locationbar
type dom.event.contextmenu.enabled in the input
change the value to false by leftclicking twice on it

This is unlikely to ever go to into options by default.

You can use the extension JSoptions at
http://www.blueprintit.co.uk/~dave/web/firefox/jsoptions/index.html

WONT ?

Comment 2

14 years ago
But I believe that in Firefox 1.0.2 this option can still be changed with
"Disable or replace context menus" in the advanced Javascript options.
(In reply to comment #2)
> But I believe that in Firefox 1.0.2 this option can still be changed with
> "Disable or replace context menus" in the advanced Javascript options.
Yes, and it was removed from  Options because the avg user hasn't got a clue
what it means

Comment 4

13 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > But I believe that in Firefox 1.0.2 this option can still be changed with
> > "Disable or replace context menus" in the advanced Javascript options.
> Yes, and it was removed from  Options because the avg user hasn't got a clue
> what it means
> 

It would be nice if it were put back in, I liked having the freedom to disable
only the javascript annoyances that **** me off... alternatively, Firefox should
notify whenever it disables the functionality of any kind of javascript on a
page, in a very unobtrusive way, perhaps in the status bar.  I might file a bug
for this..
(In reply to comment #4)
Read comment #1

-> WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 6

13 years ago
*** Bug 298016 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
Setting
dom.event.contextment.enable
to "false" doesn't work me with Firefox 1.0.4 and everything in Advanced
javaScript Options is un-selected.

This page still blocks right click
http://www.lemon-monkey.com/gallery/
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.