Scroll view problems in Mail composer address list

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: mats, Assigned: mats)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

14 years ago
I'm guessing this is caused by the recent scroll frame changes, please reassign
if I'm mistaken.

STEPS TO REPRODUCE:
1. Start Mozilla and open a Mail composition window
2. enter 5-6 recipients to trigger the vertical scrollbar
3. scroll to the end
4. scroll to the top

ACTUAL BEHAVIOUR:
An unnecessary horizontal scrollbar is created. 100% reproducible.
(the view is blank in the scrolled-to region to the right).

PLATFORMS & BUILDS TESTED:
Mozilla nightly trunk build 2005-04-08-05 on Linux (GTK1)
I can't reproduce this but maybe I'm not doing the right steps. Screenshot?
(Assignee)

Comment 2

14 years ago
Created attachment 180343 [details]
Screenshot #1
(Assignee)

Comment 3

14 years ago
Created attachment 180344 [details]
Screenshot #2 (scrolled to the right)
I'm still not reproducing this. I tried Modern and that wasn't it. Looks like
you'll have to do this yourself Mats :-)
You might want to try the patch in bug 289431 first though...
(Assignee)

Comment 6

14 years ago
Created attachment 180543 [details]
Screenshot #3 (blank space at top in address list)
(Assignee)

Comment 7

14 years ago
Bug still occurs, 2005-04-12-05 Linux GTK1 (which includes the fix for
bug 289431). I can also reproduce in a fresh debug build on Linux (GTK2).
It seems that a precondition for the bug to appear is that the auto-complete
dropdown menu has triggered.

The following sequence always reproduces the bug for me:
1. open a Mail compositon window
2. click on the first address field and type a character that triggers the
   auto-complete dropdown menu, when the menu appears type ESC to close it,
   now type '@' followed by RETURN
3. type '@' followed by RETURN seven times (or enough to trigger a vertical
   scrollbar).
4. scroll to the top (mouse wheel or kbd) => horizontal scrollbar appears

Another problem that I have seen is that when resizing the height of the
address list using the horizontal splitter there is sometimes a blank area
*above* the address field visible at the top (see Screenshot #3).
That could be an unrelated problem though.

Comment 8

14 years ago
I'm seeing a regression between linux trunk 2004071405 and 2004071506
Keywords: regression
(Assignee)

Comment 9

14 years ago
*** Bug 290582 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
this worksforme with builds since 20050415 (bug 285449, I guess)
(Assignee)

Comment 11

14 years ago
WFM, 2005-04-16-05 Linux GTK1, the horizontal scrollbar does not appear.
Resizing the address list using the splitter is now broken though.
I filed bug 290681 on that.  I'm keeping this bug open until I can verify
that both problems reported here are gone after bug 290681 is fixed.
Assignee: roc → mats.palmgren
Depends on: 290681
(Assignee)

Updated

14 years ago
Depends on: 290464
No longer depends on: 290681
(Assignee)

Comment 12

14 years ago
WFM, 2005-04-18-05 Linux GTK1. It seems this bug was fixed by bug 290464.
I filed bug 290865 on the gap noted in comment 7 and bug 290861 on another
issue with the layout of the Mail recipient list.

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 13

14 years ago
(well it was probably bug 285449 that fixed this as Andrew noted)
You need to log in before you can comment on or make changes to this bug.