If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Print Preview Ignores margins set to zero

RESOLVED DUPLICATE of bug 221706

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 221706
13 years ago
13 years ago

People

(Reporter: Emily Clarke, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

If you have a CSS print media specification that indicates the margin, padding
and border are zero, and set the margins in Firefox to zero, Firefox still
previews a margin (appears to be 1/2") around the box.

Reproducible: Always

Steps to Reproduce:
1.In XP, set up a pin fed printer (Epson FX-100 will do)
2.File/Page Setup and set all margins to zero
3.Load the sample page in Firefox and do File/Print Preview
4. Notice the borders are not set to zero
5) Repeat 3 and 4 in Internet Explorer. Notice borders are zero.

Actual Results:  
There is a border around the table that shouldn't be there.

Expected Results:  
There should be no border around the table.  Although CSS defines media="print"
as a block format, this does not mean it shouldn't support zero borders.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 221706 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.