Crash closing about:config with ctrl+w (only) in tab, filter textbox in focus

VERIFIED DUPLICATE of bug 289430

Status

()

Firefox
General
--
critical
VERIFIED DUPLICATE of bug 289430
13 years ago
13 years ago

People

(Reporter: William Price, Assigned: Blake Ross)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050409 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050409 Firefox/1.0+

Closing a tab that is displaying about:config will crash the browser
if-and-only-if (so it seems) the following conditions are all true:

- (Previously loaded?) tab contains a previously **non-cached/unvisited** page
- about:config is opened in a new tab in the same window (not a different window)
- The about:config tab has the filter textbox focused
- Ctrl+W is used (not the X button) to close the about:config tab

Reproducible: Always

Steps to Reproduce:
1. Load a non-cached page in a tab (I've been using the 1st tab after browser load)
2. Open a new tab; load about:config
3. Leave the filter textbox in-focus
4. Press Ctrl+W to close the tab

Actual Results:  
Application crash

Expected Results:  
Closed the about:config tab

This happened on an existing and a new, default profile; not extension dependent.
See TB4973437Z, TB4973301X.
(Reporter)

Comment 1

13 years ago
blocking-aviary1.1 => ?
added keywords: regression, crash
Keywords: crash, regression
Version: unspecified → Trunk
(Reporter)

Comment 2

13 years ago
didn't take blocking request; sorry for bugspam
Flags: blocking-aviary1.1?
duping

if you put the cursor in the locationbar you can close the tab w/o crash

*** This bug has been marked as a duplicate of 289430 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
Flags: blocking-aviary1.1?
You need to log in before you can comment on or make changes to this bug.