2 errors detected in the compilation of nsHttpAuthManager.cpp

RESOLVED FIXED in mozilla1.8beta3

Status

()

--
blocker
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: g.fischer, Assigned: Biesinger)

Tracking

Trunk
mozilla1.8beta3
SGI
IRIX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; IRIX64 IP27; en-US; rv:1.8b) Gecko/R-A-C
Build Identifier: 

irix 6.5.27, mipspro 7.42, cvs checkout.
same with current cvs firefox!
-------------

--- C++ prelinker: nsHttpAuthManager.o ---
 CC -DEFAULT:abi=n32:isa=mips4:proc=r10k -c -DMOZILLA_INTERNAL_API
"-DOSTYPE=\"IRIX6\"" "-DOSARCH=\"IRIX\"" -DBUILD_ID=2005041102 -DIMPL_NS_NET
-I../../../../../mozilla/netwerk/protocol/http/src/../../../base/src
-I../../../../../mozilla/xpcom/ds -I../../../../dist/include/xpcom
-I../../../../dist/include/string -I../../../../dist/include/pref
-I../../../../dist/include/nkcache -I../../../../dist/include/mimetype
-I../../../../dist/include/intl -I../../../../dist/include/unicharutil
-I../../../../dist/include/caps -I../../../../dist/include/xpconnect
-I../../../../dist/include/js -I../../../../dist/include/uconv
-I../../../../dist/include/necko -I../../../../dist/include
-I../../../../dist/include/nspr -I../../../../dist/sdk/include -KPIC
-I/usr/local/include -I/usr/nekoware/include -LANG:exceptions=OFF -woff 3262 -G
4 -n32 -DNDEBUG -DTRIMMED -O3 -I/usr/local/include -I/usr/nekoware/include
"-DMOZILLA_VERSION=\"1.8b2\"" -DMOZILLA_VERSION_MAJOR=1
-DMOZILLA_VERSION_MINOR=8 -DIRIX=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1
-DD_INO=d_ino -DSTDC_HEADERS=1 -DHAVE_ST_BLKSIZE=1 -DHAVE_SIGINFO_T=1
-DHAVE_INT16_T=1 -DHAVE_INT32_T=1 -DHAVE_INT64_T=1 -DHAVE_UINT=1 -DHAVE_UINT_T=1
-DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_MEMORY_H=1
-DHAVE_UNISTD_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_MALLOC_H=1 -DHAVE_X11_XKBLIB_H=1
-DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1 -DHAVE_SYS_CDEFS_H=1 -DHAVE_LIBM=1
-DHAVE_LIBDL=1 -DHAVE_LIBSOCKET=1 -DFUNCPROTO=15 -DHAVE_XSHM=1 -DHAVE_RANDOM=1
-DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1
-DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DHAVE_STAT64=1 -DHAVE_LSTAT64=1
-DHAVE_FLOCKFILE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_STRTOK_R=1
-DHAVE_LANGINFO_CODESET=1 -DHAVE_I18N_LC_MESSAGES=1
"-DMOZ_DEFAULT_TOOLKIT=\"gtk2\"" -DMOZ_WIDGET_GTK2=1 -DMOZ_ENABLE_XREMOTE=1
-DMOZ_X11=1 -DMOZ_BUILD_APP=suite "-DMOZ_DISTRIBUTION_ID=\"org.mozilla\""
-DMOZ_ENABLE_XFT=1 -DOJI=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -DACCESSIBILITY=1
-DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DMOZ_XTF=1 -DHAVE_GSSAPI_GSSAPI_H=1
-DMOZ_MATHML=1 -DMOZ_LOGGING=1 "-DMOZ_USER_DIR=\".mozilla\"" -DMOZ_XUL=1
-DMOZ_PROFILELOCKING=1 "-DMOZ_DLL_SUFFIX=\".so\"" -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1
-DJS_THREADSAFE=1 -DNS_PRINT_PREVIEW=1 -DNS_PRINTING=1 -DMOZ_ACCESSIBILITY_ATK=1
"-DMOZILLA_LOCALE_VERSION=\"1.8b2\"" "-DMOZILLA_REGION_VERSION=\"1.8b2\""
"-DMOZILLA_SKIN_VERSION=\"1.5\"" -D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT
../../../../../mozilla/netwerk/protocol/http/src/nsHttpAuthManager.cpp -o
nsHttpAuthManager.o
cc-1640 CC: WARNING File =
../../../../../mozilla/netwerk/protocol/http/src/../../../base/src/nsURLHelper.h,
Line = 204
  pointer operation result is out of range

      return net_FindCharInSet(str, NET_MAX_ADDRESS, set);
                                    ^

cc-1640 CC: WARNING File =
../../../../../mozilla/netwerk/protocol/http/src/../../../base/src/nsURLHelper.h,
Line = 208
  pointer operation result is out of range

      return net_FindCharNotInSet(str, NET_MAX_ADDRESS, set);
                                       ^

cc-1070 CC: ERROR File = ../../../../dist/include/xpcom/nsCOMPtr.h, Line = 187
  The indicated type is incomplete.

  class nsDerivedSafe : public T
                               ^
          A template was detected during header processing.
            instantiation of class "nsDerivedSafe<nsIVariant>" at line 330 of
                      "../../../../../mozilla/xpcom/ds/nsBaseHashtable.h"
            instantiation of "PLDHashOperator nsBaseHashtable<nsStringHashKey,
                      nsCOMPtr<nsIVariant>, nsIVariant
                      *>::s_EnumReadStub(PLDHashTable *, PLDHashEntryHdr *,
                      PRUint32, void *)" 

cc-1387 CC: ERROR File = ../../../../../mozilla/xpcom/ds/nsBaseHashtable.h, Line
= 330
  No suitable conversion function from "nsCOMPtr<nsIVariant>" to "nsIVariant *"
          exists.

    PLDHashOperator res = (eargs->func)(ent->GetKey(), ent->mData, eargs->userArg);
                                                       ^
          detected during instantiation of "PLDHashOperator
                    nsBaseHashtable<nsStringHashKey, nsCOMPtr<nsIVariant>,
                    nsIVariant *>::s_EnumReadStub(PLDHashTable *,
                    PLDHashEntryHdr *, PRUint32, void *)" 

2 errors detected in the compilation of
"../../../../../mozilla/netwerk/protocol/http/src/nsHttpAuthManager.cpp".
C++ prelinker: Error compiling nsHttpAuthManager.o
gmake[5]: *** [libnkhttp_s.a] Error 2


Reproducible: Always

Updated

14 years ago
Assignee: nobody → darin
Component: Build Config → Networking: HTTP
Product: Mozilla Application Suite → Core
QA Contact: build-config → networking.http
Version: unspecified → Trunk

Comment 1

14 years ago
*** Bug 289748 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

14 years ago
seems like nsCOMPtr.h is the bad guy...
(Reporter)

Comment 3

14 years ago
just tried deer park a1 and got this error, too :-(
(Reporter)

Comment 4

14 years ago
maybe it helps to know that this also happened with thunderbird 1.1a.
Created attachment 185363 [details] [diff] [review]
possible patch

does this patch help?
(Reporter)

Comment 6

14 years ago
wow, so fast !
will try it now...
> wow, so fast !

nearly two months? I guess that counts as fast here.
(Reporter)

Comment 8

14 years ago
(In reply to comment #7)
> > wow, so fast !
> 
> nearly two months? I guess that counts as fast here.
> 

hehe, well, they were faster last year ;-)
(Reporter)

Comment 9

14 years ago
(In reply to comment #5)
> Created an attachment (id=185363) [edit]
> possible patch
> 
> does this patch help?


yes, works fine with thunderbird but firefox deer park a1 now shows:

cc-1020 CC: ERROR File = ../../../../mozilla/gfx/src/gtk/nsGfxFactoryGTK.cpp,
Line = 155
  The identifier "nsIFontEnumerator" is undefined.

    nsIFontEnumerator *result;
    ^

cc-1020 CC: ERROR File = ../../../../mozilla/gfx/src/gtk/nsGfxFactoryGTK.cpp,
Line = 155
  The identifier "result" is undefined.

    nsIFontEnumerator *result;
                       ^

2 errors detected in the compilation of
"../../../../mozilla/gfx/src/gtk/nsGfxFactoryGTK.cpp".

anyway, the gtk2 version seems to run fine.
(Reporter)

Comment 10

14 years ago
correction:

seems like the default for tb is now gtk2 so both builds are gtk2.
this may be the reason why tb didn't have problems.
Attachment #185363 - Flags: superreview?(darin)
Attachment #185363 - Flags: review?(shaver)
hm, not sure why you get that error. what's the mozconfig for a failing build?
maybe it would be better to file that as a separate bug.
Assignee: darin → cbiesinger
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → mozilla1.8beta3
Comment on attachment 185363 [details] [diff] [review]
possible patch

r+sr+a=shaver for bustage
Attachment #185363 - Flags: superreview?(darin)
Attachment #185363 - Flags: superreview+
Attachment #185363 - Flags: review?(shaver)
Attachment #185363 - Flags: review+
Attachment #185363 - Flags: approval1.8b3+
Checking in xpcom/ds/nsHashPropertyBag.h;
/cvsroot/mozilla/xpcom/ds/nsHashPropertyBag.h,v  <--  nsHashPropertyBag.h
new revision: 1.4; previous revision: 1.3
done


please file the problem in gfx/ as another bug.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

14 years ago
(In reply to comment #13)
> Checking in xpcom/ds/nsHashPropertyBag.h;
> /cvsroot/mozilla/xpcom/ds/nsHashPropertyBag.h,v  <--  nsHashPropertyBag.h
> new revision: 1.4; previous revision: 1.3
> done
> 
> 
> please file the problem in gfx/ as another bug.

filed it already. over 2 months ago!
#288976
You need to log in before you can comment on or make changes to this bug.