Inconsistent behaviour with HTML Comment

VERIFIED WONTFIX

Status

()

VERIFIED WONTFIX
14 years ago
14 years ago

People

(Reporter: mozilla, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Related to Bug #249913, #245740, #236591

The above three bugs list HTML comments (i.e. <!-- -->) with two hyphens in them
as correct/intended behaviour.

If this is intended behaviour, why is it inconsistent between HTML 4.0 and HTML
4.01 DOCTYPEs?

I.e., when the DOCTYPE is changed from:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

to

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

Firefox "incorrectly" parses
<!-- -- -->
as a comment (like IE does).


Reproducible: Always

Steps to Reproduce:



Expected Results:  
Firefox should act consistently between HTML 4.0 and HTML 4.01 DOCTYPEs.
It should preferably treat the entire contents of
<!--  <<comment>> -->
as a comment; I've already stumbled across many web pages that have
double-hyphens in comments, and as a result, some become unusable.

Comment 1

14 years ago
Resolving wontfix, the inconsistencies are intended.

Mozilla/Firefox endeavors to follow relevant standards documents--but not to the
point of being unuseable for browsing public websites.  So, there are different
"modes" used; changing the DOCTYPE in your example changes the mode.  Sometimes
comments are parsed according to the standard, other times a more loose
definition is used.

This is documented at http://www.mozilla.org/docs/web-developer/quirks/.  The
comments quirk is documented at the very end of
http://www.mozilla.org/docs/web-developer/quirks/quirklist.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.