All users were logged out of Bugzilla on October 13th, 2018

Option to save page as html.tar.gz and read such a page

RESOLVED DUPLICATE of bug 64286

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 64286
14 years ago
14 years ago

People

(Reporter: garcia_arboleya, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

When saving a web page from the browser, doing "file", "Save page as", I would
like to have in this dialog an aditional checkbox saying something like "Save in
compressed format".

When selected, all the html and additional files could be written in a tar.gz file.

Would be also nice that Firefox recognices the .html.tar.gz extension of this
files and be able to open them directly.

In this way would be easier to make backups of webs, or to redistribute them as
a single file. Or even to distribute more general documents without using
propietary formats like .doc




Reproducible: Always

Steps to Reproduce:
1. Click on file in the menu
2. Click "Save page as"
3. A dialog window will appear

Actual Results:  
The dialog that appears have the "File Name" field and the folder were to put it.
On clicking OK, the page will be saved as html, and a subdirectory with all the
related files will be created in the same directory.

Expected Results:  
An aditional checkbox should be added to the dialog.
If checked, a single compressed file should be created, containing all the
information of the web page that was in the extra directory.
extension material

WONT ?

Updated

14 years ago
Summary: New Feature Request → Option to save page as html.tar.gz and read such a page

Comment 2

14 years ago
This is essentially a dup of bug 64286.

*** This bug has been marked as a duplicate of 64286 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.